ПОМОГИТЕ13217
24.10.2021 03:42

X^y+) на паскале нужно написать программу для решения

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Кристинаголубь
26.08.2020 12:26
// PascalABC.NET 3.2, сборка 1427 от 24.04.2017
// Внимание! Если программа не работает, обновите версию!

function Pow(x,y:BigInteger):BigInteger;
begin
  Result:=x;
  for var i:=int64(2) to int64(y) do Result*=x
end;

begin
  var x,y:integer;
  Write('Введите натуральные х и у: '); Read(x,y);
  if (x<=0) or (y<=0) then begin
    Writeln('Неверный ввод'); Exit
    end;
  if x=1 then Writeln('Результат: ',y+1)
  else begin
    var x1:=Range(2,x).Aggregate(BigInteger(1),(a,b)->a*b);
    Writeln('Результат ',Pow(x,y)+Pow(y,x1))
    end
end.

Пример
Введите натуральные х и у: 5 8
Результат 2348542582773833227889480596789337027375682548908319870707290971532209025114608443463698998384768703032325601
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота