valeria8002
27.02.2021 21:22

Составить программу, которая в строку S записывает символы строки S1 в обратном порядке
Пример:
Введите строку: abcdef
Строка новая: fedcba
4. Составить программу, которая должна считать, сколько раз в строке S встречается символ «а».

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
DSenTinor1
30.01.2020 09:50

Решение Pascal

Delphi/Pascal

program Case5;

var

 N,A,B:Integer;

begin

 Write('Введите номер действия: ');

 Readln(N);

 Write('Введите число A: ');

 Readln(A);

 Write('Введите число B: ');

 Readln(B);

 

 Case N of

   1: Writeln(A+B);

   2: Writeln(A-B);

   3: Writeln(A*B);

   4: Writeln(A/B);

 end;

end.

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

program Case5;

var

 N,A,B:Integer;

begin

 Write('Введите номер действия: ');

 Readln(N);

 Write('Введите число A: ');

 Readln(A);

 Write('Введите число B: ');

 Readln(B);

 

 Case N of

   1: Writeln(A+B);

   2: Writeln(A-B);

   3: Writeln(A*B);

   4: Writeln(A/B);

 end;

end.

 

Решение C

C

#include <stdio.h>

 

int main(void)

{

  system("chcp 1251");

  int n;

  float a,b;

  printf("N:") ;

  scanf ("%i", &n);

  printf("A:") ;

  scanf ("%f", &a);

  printf("B:") ;

  scanf ("%f", &b);

 

  switch (n) {

  case 1:

      printf("%f\n",a+b) ;

      break;

  case 2:

      printf("%f\n",a-b) ;

      break;

  case 3:

      printf("%f\n",a*b) ;

      break;

  case 4:

      printf("%f\n",a/b) ;

      break;

  }

  return 0;

}

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

#include <stdio.h>

 

int main(void)

{

  system("chcp 1251");

  int n;

  float a,b;

  printf("N:") ;

  scanf ("%i", &n);

  printf("A:") ;

  scanf ("%f", &a);

  printf("B:") ;

  scanf ("%f", &b);

 

  switch (n) {

  case 1:

      printf("%f\n",a+b) ;

      break;

  case 2:

      printf("%f\n",a-b) ;

      break;

  case 3:

      printf("%f\n",a*b) ;

      break;

  case 4:

      printf("%f\n",a/b) ;

      break;

  }

  return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
sleep13
16.09.2021 23:03

Еще в глубокой древности некоторые военачальники, следуя обычаю, не позволяли своим подчиненным казнить пленных, приказывали щадить женщин и детей, запрещали отравлять колодцы. Эти обычаи со временем оформились в нормы обычного права, которыми руководствовались противоборствующие стороны. В ряде случаев воюющие заключали письменные соглашения о соблюдении правил гуманного обращения с противником. Однако вплоть до второй половины XIX века такие соглашения не носили всеобщего характера и, как правило, действовали лишь во время одного сражения или одной войны.

Объяснение:

ВОЗМОЖНО ЭТО НЕ ПРАВИЛЬНО

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота