нагамрпапприии
26.06.2020 22:12

На вход программе подаётся непустая последовательность целых чисел оканчивающаяся отрицательным числом. Написать программу, которая подсчитает среднее арифметическое этих чисел. Последнее введённое число участвует в получении среднего арифметического. Точность выводимого числа не задаётся.
Входные данные
1 3 4 -1
Выходные данные

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
SofiDu
14.10.2020 13:00

sr = 0

a = 0

k = 0

while a >= 0:

 a = int(input())

 k += 1

 sr += a

print(sr/k)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота