Jonson2002
07.01.2021 02:48

РЕШИТЬ ЗАДАЧУ НА PYTHON.
Зная координаты точек, заданных в градусах, рассчитать расстояние между двумя заданными точками.

Входные данные
Первая строка содержит вещественные числа, содержащие не более 7 знаков после десятичной точки, географическая широта и долгота первой точки, выраженная в градусах.

Вторая строка содержит вещественные числа географическая широта и долгота второй точки, выраженная в градусах.

Выходные данные
Выведите одно число с точностью не менее 4 знаков — расстояние между географическими точками на поверхности Земли, выраженное в километрах.

Примеры
входные данные
55.735520 37.642474
55.733969 37.587093
выходные данные
3.471443
входные данные
54.351513 48.389576
54.286666 48.233494
выходные данные
12.428514

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
PaPaDeDa
16.05.2022 19:33
//Когда Глеб расстроился
//Pascal ABC.NET 3.1 сборка 1256

Var
 a,b,c,d,e:real;
 
procedure cube(a,b,c,d,e:real);
Var
 p,q,delta,phi,i:real;
 y:array[1..3] of real;
begin
p:=(3*a*c-sqr(b))/(3*sqr(a));
q:=(2*power(b,3)-9*a*b*c+27*sqr(a)*d)/(27*power(a,3));
delta:=power(q/2,2)+power(p/3,3);
if delta<0 then
 begin
  if q<0 then
   phi:=arctan(sqrt(-delta)/(-q/2));
  if q>0 then
   phi:=arctan(sqrt(-delta)/(-q/2))+pi;
  if q=0 then
   phi:=pi/2;
  y[1]:=2*sqrt(-p/3)*cos(phi/3);
  y[2]:=2*sqrt(-p/3)*cos(phi/3+(2*pi)/3);
  y[3]:=2*sqrt(-p/3)*cos(phi/3+(4*pi)/3);
  var x:=seq(y[1]-b/(3*a),y[2]-b/(3*a),y[3]-b/(3*a));
  write(x.where(x -> x<>e).where(x -> frac(x)=0).where(x -> x>=0).Where(x -> x<=1000).Distinct.Count);
 end;
if delta>0 then
 begin
  var arsom:=range(0,1000).Where(x->(a*power(x,3)+b*x*x+c*x+d)/(x-e)=0);
  write(arsom.Count);
  {Мы не виноваты, Паскаль не может в комплексные числа}
 end;
if delta=0 then
 begin
  y[1]:=2*power(-q/2,1/3);
  y[2]:=-power(-q/2,1/3);
  var x:=seq(y[1]-b/(3*a),y[2]-b/(3*a));
  write(x.where(x -> x<>e).where(x -> frac(x)=0).where(x -> x>=0).Where(x -> x<=1000).Distinct.Count);
 end;
end;

procedure square(a,b,c,e:real);
Var
 d:real;
begin
d:=sqr(b)-4*a*c;
if d<0 then writeln('0');
if d>0 then
 begin
  var x:=arr((-b+sqrt(d))/(2*a),(-b-sqrt(d))/(2*a));
  write(x.where(x -> x<>e).where(x -> frac(x)=0).where(x -> x>=0).Where(x -> x<=1000).Distinct.Count);
 end;
if d=0 then
 begin
  var x:=arr(-b/(2*a));
  write(x.where(x -> x<>e).where(x -> frac(x)=0).where(x -> x>=0).Where(x -> x<=1000).Distinct.Count);
 end;
end;

procedure common(a,b,e:real);
begin
 var x:=arr(-b/a);
 write(x.where(x -> x<>e).where(x -> frac(x)=0).where(x -> x>=0).Where(x -> x<=1000).Distinct.Count);
end;

procedure awfulvar(e:real);
begin
 if (e>=0) and (e<=1000) then writeln('1000') else writeln('1001');
end;

procedure otherawfulvar(e:real);
begin
 if e<>0 then writeln('1') else writeln('0');
end;

begin
read(a,b,c,d,e);
if (a<>0) and (b<>0) then cube(a,b,c,d,e);
if (a=0) and (b<>0) then square(b,c,d,e);
if (a=0) and (b=0) and (c<>0) and (d<>0) then common(c,d,e);
if (a=0) and (b=0) and (c=0) and (d=0) then awfulvar(e);
if (a=0) and (b=0) and (c<>0) and (d=0) then otherawfulvar(e);
if (a=0) and (b=0) and (c=0) and (d<>0) then writeln('0');
end.

Пример ввода:
1
1
1
1
1
Пример вывода:
0
0,0(0 оценок)
Ответ:
dddddkkke
15.02.2022 12:18
Математические  дроби - то есть это : ⅟ ½ ⅓ ¼ ⅕ ⅙ ⅐ ⅛ ⅑ ⅒ ⅔ ¾ ⅖ ⅗ ⅘ ⅚ ⅜ ⅝ ⅞.
Знаки тире как: длинное тире , цифровое тире , горизонтальная линия .
Математические символы такие как: ∫ ∬ ∭ ∮ ∯ ∰ ∱ ∲ ∳
∃ ∄ ∅ ∆ ∇ ∈ ∉ ∊ ∋ ∌ ∍ ∎ ∏ ∐ ∑ − ∓ ∔ ∕ ∖ ∗ ∘ ∙ √ ∛ ∜ ∝ ∟ ∠ ∡ ∢ ∣ ∤ ∥ ∦ ∧ ∨ ∩ ∪ ∴ ∵ ∶ ∷ ∸ ∹ ∺ ∻ ∼ ∽ ∾ ∿ ≀ ≁ ≂ ≃ ≄ ≅ ≆ ≇ ≈ ≉ ≊ ≋ ≌ ≍ ≎ ≏ ≐ ≑ ≒ ≓ ≔ ≕ ≖ ≗ ≘ ≙ ≚ ≛ ≜ ≝ ≞ ≟ ≠ ≡ ≢ ≣ ≤ ≥ ≦ ≧ ≨ ≩ ≪ ≫ ≬ ≭ ≮ ≯ ≰ ≱ ≲ ≳ ≴ ≵ ≶ ≷ ≸ ≹ ≺ ≻ ≼ ≽ ≾ ≿ ⊀ ⊁ ⊂ ⊃ ⊄ ⊅ ⊆ ⊇ ⊈ ⊉ ⊊ ⊋ ⊌ ⊍ ⊎ ⊏ ⊐ ⊑ ⊒ ⊓ ⊔ ⊕ ⊖ ⊗ ⊘ ⊙ ⊚ ⊛ ⊜ ⊝ ⊞ ⊟ ⊠ ⊡ ⊢ ⊣ ⊤ ⊥ ⊦ ⊧ ⊨ ⊩ ⊪ ⊫ ⊬ ⊭ ⊮ ⊯ ⊰ ⊱ ⊲ ⊳ ⊴ ⊵ ⊶ ⊷ ⊸ ⊹ ⊺ ⊻ ⊼ ⊽ ⊾ ⊿ ⋀ ⋁ ⋂ ⋃ ⋄ ⋅ ⋆ ⋇ ⋈ ⋉ ⋊ ⋋ ⋌ ⋍ ⋎ ⋏ ⋐ ⋑ ⋒ ⋓ ⋔ ⋕ ⋖ ⋗ ⋘ ⋙ ⋚ ⋛ ⋜ ⋝ ⋞ ⋟ ⋠ ⋡ ⋢ ⋣ ⋤ ⋥ ⋦ ⋧ ⋨ ⋩ ⋪ ⋫ ⋬ ⋭ ⋮ ⋯ ⋰ ⋱ ⋲ ⋳ ⋴ ⋵ ⋶ ⋷ ⋸ ⋹ ⋺ ⋻ ⋼ ⋽ ⋾ ⋿ ✕ ✖ ✚.
Символы как процент -‰
Римские цифры : Ⅰ Ⅱ Ⅲ Ⅳ Ⅴ Ⅵ Ⅶ Ⅷ Ⅸ Ⅹ Ⅺ Ⅻ
ⅰ ⅱ ⅲ ⅳ ⅴ ⅵ ⅶ ⅷ ⅸ ⅹ ⅺ ⅻ.
Цифры в кружках - ⓵ ⓶ ⓷ ⓸ ⓹ ⓺ ⓻ ⓼ ⓽ ⓾ ➊ ➋ ➌ ➍ ➎ ➏ ➐ ➑ ➒ ➓
⓪ ➀ ➁ ➂ ➃ ➄ ➅ ➆ ➇ ➈ ➉ ⑪ ⑫ ⑬ ⑭ ⑮ ⑯ ⑰ ⑱ ⑲ ⑳
❶ ❷ ❸ ❹ ❺ ❻ ❼ ❽ ❾ ❿ ⓫ ⓬ ⓭ ⓮ ⓯ ⓰ ⓱ ⓲ ⓳ ⓴
Латинские буквы в кружочках:
ⒶⒷⒸⒹⒺⒻⒼⒽⒾⒿⓀⓁⓂⓃⓄⓅⓆⓇⓈⓉⓊⓋⓌⓍⓎⓏ
ⓐⓑⓒⓓⓔⓕⓖⓗⓘⓙⓚⓛⓜⓝⓞⓟⓠⓡⓢⓣⓤⓥⓦⓧⓨⓩ
Знаки валютных купюр : $ € ¥ £ ƒ ₣ ¢ ¤ ฿ ₠ ₡ ₢ ₤
Смайлики:㋛ ソ ッ ヅ ツ ゾ シ ジ ッ ツ シ ン 〴 ت ☺ ☻ ☹
Рука , указательнйы палец и многое другое ( ✉ ✍ ✎ ✏ ✐ ✑ ✒,☚☛☜☝☞☟✌,✆ ☎ ☏,
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота