Войти
Регистрация
Спроси ai-bota
Емсимася
08.09.2020 14:23
Напишите программу с использованием цикла.
На Pascal ABC
Подсчитать среднее значение чисел от 0 до 30
Выходная информация
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
gaukhars01
08.02.2021 04:35
Для хранения растрового изображения размером 512 x 128 пикселей отвели 64 Кбайт памяти Каково максимальное возможное число цветов в палитре изображения ...
милаха3451
08.12.2022 18:22
Установи соответствие: 1) pygame.display.get_caption2) pugame.display,.set_modeа) закрывает предыдущий экранб) установка текущего окна заголовка...
Lesha152
03.08.2021 16:24
Какой объем информации занимает черно-белое изображение с размером НУЖЕН ОТВЕТ ...
Выгуки
21.01.2022 05:27
Как называются сведения об объектах и явлениях окружающей среды, их параметрах, свойствах и состояниях, которые уменьшают имеющуюся о них степень неопределенности, неполноты знаний?...
madina2421
22.03.2021 00:55
Перевести число 1328 в десятичную систему счисления a) 80 b) 90 c) 45 d) 19...
Georgiy111111
09.04.2020 21:06
Критерии оценки -определение понятия БД и СУБД согласно с общепринятым определением дано верно; -определение понятия реляционной модели согласно с общепринятым определением дано...
ilyazavrik
03.11.2021 12:17
Реализовать поиск оптимального решения уравнения, найти корни уравнения 4х1-7х2+7х3+8х4=1 3х1-6х2+7х3+7х4=3 3х1-6х2+6х3+8х4=2 2х1-4х2+5х3+5х4=3...
annvggf
02.05.2022 12:11
Аочный Экзамен Информационные технологии, экзамен с2 А = 0,4345 ет ответа ДА = 0,022 Округляя результат А до одной сомнительной цифры, получаем 1.00 метить Выберите один ответ:...
MarinaRaim26
11.07.2021 02:10
паскаль Составить алгоритм знания теории физики. Алгоритм должен вывести вопрос и три варианта ответа. Пользователь должен выбрать правильный ответ и ввести его номер. В случае...
ban8
05.06.2021 01:40
Выберите из предложенных вариантов основные записи алгоритмов *Словесное описаниеСхемаПострочная записьЧертежПоследовательность рисунковДиаграммаЗапись на алгоритмическом языкеБлок-схема...
Ответ:
marisa10
26.11.2021 09:33
[l,r,строка,номер]
[0, 0, "a", 1]
[1, 1, "b", 2]
[1, 2, "bb", 3]
[2, 2, "b", 4]
[0, 3, "abba", 5]
[3, 3, "a", 6]
[3, 4, "aa", 7]
[4, 4, "a", 8]
[3, 5, "aaa", 9]
[4, 5, "aa", 10]
[5, 5, "a", 11]
[3, 6, "", 12]
[4, 6, "aaa", 13]
[5, 6, "aa", 14]
[6, 6, "a", 15]
[2, 7, "bb", 16]
[7, 7, "b", 17]
[6, 8, "aba", 18]
[8, 8, "a", 19]
[7, 9, "bab", 20]
[9, 9, "b", 21]
#код программы Ruby 22
s = "abbbab"
n = 0
for r in 0..s.size-1
for l in 0..r
t = s[l..r]
if t.reverse == t
n += 1
p [l,r,t,n]
end
end
end
0,0
(0 оценок)
Ответ:
vlada363
16.03.2020 21:38
Думаю нет большой разницы между процедурой и функцией, просто функция куда удобнее.
Для нахождения нода используется алгоритм Эвклида
//PascalABC.Net
function NOD(A, B: integer): integer;
begin
while A <> B do
if A > B then A := A - B else B := B - A;
NOD := A;
end;
procedure pNOD(A, B: integer; var NOD: integer);
begin
while A <> B do
if A > B then A := A - B else B := B - A;
NOD := A;
end;
begin
var a: Array of integer := (16, 32, 40, 64, 80, 128);
var n := a[low(a)];
for var i := low(a) to high(a) do
pNOD(n, a[i], n);
Writeln(n);
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота