dok12369
16.01.2021 18:36

Написать программу для гахождения перимитра равностороннего треугольника

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ник5046
16.12.2022 20:06
Program zadacha;varA: array[1..8] of integer;i,kolvo_pol,proiz_otr: integer;beginfor i:=1 to 8 do read(A[i]);kolvo_pol:=0;proiz_otr:=1;
for i:=1 to 8 do beginif A[i]>0 then kolvo_pol:=kolvo_pol+1;end;writeln();writeln('kolvo_pol = ', kolvo_pol);
for i:=1 to 8 do beginif A[i]<0 then proiz_otr:=proiz_otr*A[i];end;writeln('proiz_otr= ', proiz_otr);end.

program zadacha;varC: array[1..10] of integer;i: integer;beginfor i:=1 to 10 do read(C[i]);writeln();
for i:=1 to 10 do beginif C[i]>0 then C[i]:=sqr(C[i]);end;
for i:=1 to 10 do beginif C[i]<0 then C[i]:=20;end;
for i:=1 to 10 do write(C[i]:6);end.
0,0(0 оценок)
Ответ:
andrejpuzanov90
16.12.2022 20:06
1. Современное решение

// PascalABC.NET 3.2, сборка 1367 от 20.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var c:=ReadArrInteger('Введите элементы массива: ',10);
  c.Transform(x->x>0?x*x:x=0?x:20); c.Println
end.

Пример
Введите элементы массива:  5 11 -7 0 3 -12 -8 1 9 -2
25 121 20 0 9 20 20 1 81 20

2. Традиционное "школьное" решение

const
  n=10;
var
  i:integer;
  c:array[1..n] of integer;
begin
  Write('Введите элементы массива: ');
  for i:=1 to n do Read(c[i]);
  for i:=1 to n do
    if c[i]>0 then c[i]:=sqr(c[i])
    else
      if c[i]<0 then c[i]:=20;
  for i:=1 to n do Write(c[i],' ');
  Writeln
end.

3. Улучшенное "школьное" решение

const
  n=10;
var
  i,t:integer;
  c:array[1..n] of integer;
begin
  Write('Введите элементы массива: ');
  for i:=1 to n do begin
    Read(t);
    if t>0 then c[i]:=t*t
    else
      if t<0 then c[i]:=20
    end;
  for i:=1 to n do Write(c[i],' ');
  Writeln
end.

Решите на 4 или на 5 9 класс,массивы на 4 дан массив а(8) ввод данных с клавиатуры.найти произведени
Решите на 4 или на 5 9 класс,массивы на 4 дан массив а(8) ввод данных с клавиатуры.найти произведени
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота