SMKate
09.09.2020 13:04

Написать программу в паскале.предложение состоит из слов, между словами один пробел, а после последнего слова точка. найти длину самого длинного слова

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
liza2005yakovl
08.07.2020 01:43
var
  x: array of string;
  y: string;

begin
  //readln(y);
  y := 'Привет мой дорогой и прекрасный умопомрач мир';
  x := y.Remove(y.Length - 1).Split(' ');
  y := x[0];
  foreach w: string in x do
    if (y.Length <= w.Length) then
      y := w;
  writeln(y.Length);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота