superfrap320
11.02.2021 00:15

не проблема :)
Задание
Изучите внешний вид системы программирования Турбо Паскаль.
Общая структура программы на языке Паскаль:
Рrogram ИМЯ..; {заголовок программы}
Uses ...; {раздел описания модулей}
Var ..; {раздел объявления переменных}
...
Begin {начало исполнительной части программы}
... {последовательность
... операторов}
End. {конец программы}
Пример программы, которая осуществляет сложение двух чисел и выводит сумму на экран:
Program Summa;
Uses
Crt;{Подключаем модуль Crt}
Var
number1, {переменная, в которой будет содержаться первое число}
number2, {переменная, в которой будет содержаться второе число}
rezult {переменная, в которой будет содержаться результат}:
integer; {указывает тип целых чисел}
Begin
ClrScr;{Используем процедуру очистки экрана из модуля Crt}
Write ('Введите первое число ');
{Выводим на экран символы, записанные между апострофами}
Readln (number1);
{Введенное пользователем число считываем в переменную number1}
Write ('Введите второе число ');
{Выводим на экран символы, записанные между апострофами}
Readln (number2);
{Введенное пользователем число считываем в переменную number2}
rezult := number1 + number2;
{Находим сумму введенных чисел и присваиваем переменной rezult}
Write ('Сумма чисел ', number1, ' и ', number2, ' равно ', rezult);
{Выводим на экран строчку, содержащую ответ задачи}
Readln;{Процедура задержки экрана)
End.

ответьте на во Какое назначение переменных number1, number2, rezult?
2. Что обозначает строка: number1, number2, rezult : integer; ?
3. Если присвоить переменным number1 и number2 соответственно значение 5 и 7, то какую строчку выдаст компьютер при исполнении последней процедуры Write? Запишите ее в отчет.
4. Переведите с английского языка слова: Write, Read. Как вы думаете, что должен делать операторы с таким названием?
5. Как вы понимаете запись: readln(number1); ?
6. Чему равно значение переменной rezult после выполнения оператора: rezult := number1 + number2; ?
1. Что делает оператор присваивания в этой программе?

Задание
ответьте на во Что такое среда программирования?
2. Опишите среду программирования Тurbo Pascal.
3. Как сохранить текст программы в Тurbo Pascal?
4. Какова структура программы на языке Pascal?
5. Как осуществить запуск программы?

Задание № 5.
Сделать вывод о проделанной практической работе.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
mariee875maria
19.02.2020 22:46

главное меню  расположено в верхней строке окна заключает в себе все возможности программы, рассортированные по более или менее однотипным . для входа в меню необходимо либо воспользоваться мышью, либо нажать f10, затем перемещаться по меню с клавиш курсором. покинуть меню можно, нажав клавишу esc.

панели  – две равноправные таблицы, занимающие основную часть окна. внутри панелей может отображаться различная информация. одна из панелей является активной (на ней находится курсор и заголовок панели подсвечен), другая панель – пассивная. смена активное панели достигается нажатием tab или щелчком мыши в любой части панели. при этом курсор перемещается с одной панели на другуюкомандная строкаменю функциональных клавиш  запуск команд ms-dos из командной строкипросмотр содержимого файларедактирование файла встроенным редактором.копирование файла или каталогапереименование и перенос файла или каталога.создание нового каталогаудаление файлов и каталоговработа с группами файлов и каталогов

0,0(0 оценок)
Ответ:
bosschakalev
02.02.2021 04:25
В позиционной системе каждый разряд стоит на своей позиции.
Например, в 10-ной системе, число 235 означает, что в нем 2 сотни, 3 десятка и 5 единиц.
В 2-ной системе число 10010 означает, что в нем 1 число 2^4 = 16 и
1 число 2^1 = 2. Таким образом, эта запись означает число 16 + 1 = 18.
В непозиционной системе разные единицы могут быть в разных местах, а их значение определяется взаимным расположением.
Самая известная непозиционная система - это римские цифры.
Запись IV означает 5 - 1 = 4, запись VI означает 5 + 1 = 6.
Запись IX означает 10 - 1 = 9, запись XI означает 10 + 1 = 11.
То есть значение значка I означает то +1, то -1, в зависимости от того, стоит он перед или после более старшего значка.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота