prostotak1970
06.10.2020 06:38

1. Проанализируйте данную
программу и составьте
аналогичную, определяющую
произведение цифр заданного
натурального числа, < 1000.
2. Составьте программу и блок-
схему для этой же задачи, но с
использованием операторов
REPEAT-UNTIL (Цикл-ДО а то никто не может решить((​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vvvvcrrrq
31.08.2022 07:09

В КНР стандартом грамотности считается освоение 1500 знаков (в сельской местности) или 2000 знаков (в городах, а также для рабочих и служащих на селе). 
3000 иероглифов достаточно для чтения газет и неспециализированных журналов. 
Большие однотомные толковые или двуязычные словари включают, как правило, 6000—8000 иероглифов. Среди этого объёма уже немало весьма редко используемых иероглифов, например, используемые в названиях ритуальных предметов древности или медикаментов традиционной китайской медицины.

0,0(0 оценок)
Ответ:
hoivamvrot
29.11.2020 18:09
Var
    money: array[1..7]of integer;
    count: array[1..7]of integer;
    s, i: integer;

begin
    money[1] := 1;
    money[2] := 2;
    money[3] := 5;
    money[4] := 10;
    money[5] := 50;
    money[6] := 100;
    money[7] := 500;
    
    write('s = ');
    readln(s);
    
    i := 7;
    repeat
        if s >= money[i] then begin
            s := s - money[i];
            count[i] := count[i] + 1;
        end
        else i := i - 1;
    until s <= 0;
    
    for i := 7 downto 1 do
        if count[i] > 0 then
            writeln(money[i], ' p. = ', count[i], ' шт.')
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота