alenka1408
12.02.2023 16:24

PASCAL Дан целочисленный массив из 20 элементов, из промежутка [-100; 50]. Напишите программу
позволяющую найти и вывести минимальное значение среди положительных элементов
массива, кратных 5 Если в исходном массиве нет элемента, значение которого положительно
и делится на 5, то вывести сообщение «Не найдено».

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ekateria1411
02.12.2020 11:21

var  

i, answer: integer;

arr: array[-100..50] of integer;

begin

answer := -1;

for i:= 0 to 19 do

begin

 read(arr[i]);

 if ((arr[i] > 0) and (arr[i] mod 5 = 0) and (arr[i] > answer)) then answer := arr[i];

end;

   if answer = -1 then writeln('Не найдено')

   else writeln(answer);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота