Ʈгiceгatoρѕ
11.10.2020 01:23

Определите значение переменной s после фрагмента программы: a=6;s=0;Repear s:=s + a; a:= a - 1; Until a=2; write (s)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Veravera002003004049
07.09.2022 15:42

#include <iostream>

using namespace std;

signed main(){

   const int n = 20;

   int arr[n], max_value, min_value, max_index = 0, min_index = 0;

   for(int i = 0; i < n; i++)

       cin >> arr[i];

   max_value = min_value = arr[0];

   for(int i = 1; i < n; i++){

       if(arr[i] > max_value){

           max_value = arr[i];

           max_index = i;

       }

       if(arr[i] < min_value){

           min_value = arr[i];

           min_index = i;

       }

   }

   swap(arr[max_index], arr[min_index]);

   for(int i = 0; i < n; i++)

       cout << arr[i] << " ";

}

0,0(0 оценок)
Ответ:
danul1414
13.01.2023 03:53

#include<iostream>

#include<vector>

#include<iterator>

#include<ranges>

using namespace std;

int main()

{

vector<int> vec;

int sum=0;

istream_iterator<int> it{cin};

istream_iterator<int> end{};

while(it!=end)

{

vec.push_back(*it);

it++;

}

for(int i:vec | views::filter([](int i){return i%2==0;}))

{

sum+=i;

}

cout<<sum<<endl;

return 0;

}

2:

#include<iostream>

using namespace std;

int main()

{

int sum=0;

for(int i=2;i<=32;i+=3)

{

sum+=i;

}

cout<<sum<<endl;

return 0;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота