SuperNikc
27.03.2022 10:55

Составьте программу, которая заполняет массив 6х6 следующим образом:
А)
1 0 0 0 0 0
0 1 0 0 0 0
0 0 1 0 0 0
0 0 0 1 0 0
0 0 0 0 1 0
0 0 0 0 0 1

Б)
1 0 0 0 0 0
1 1 0 0 0 0
1 1 1 0 0 0
1 1 1 1 0 0
1 1 1 1 1 0
1 1 1 1 1 1

В)
1 0 0 0 0 1
0 1 0 0 1 0
0 0 1 1 0 0
0 0 1 1 0 0
0 1 0 0 1 0
1 0 0 0 0 1

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dem0N1
04.07.2020 16:11
Для начала посчитаем, сколько бит информации было передано:
2 минуты и 45 секунд = 165 секунд
165 с * 128000 бит/с = 21120000 бит

Теперь вспомним, что такое частота дискретизация и уровни квантования. Дело в том, что аудио сигнал - это такая прикольная сложная синусоида. Чтобы записать сигнал в цифровом виде, каждую секунду сигнала как бы делят на промежутки (количество этих промежутков в секунде и есть частота дискретизации). Для каждого из этих промежутков записывается что-то вроде среднего значения высоты. Количество возможных значений - количество уровней квантования.
Но это так - если говорить очень упрощённо. Подробнее прочитайте в своём учебнике информатики.

Итак - у нас 256 уровней квантования. Значит каждое из значений можно записать 8 битами.
И на секунду у нас приходится 22000 таких записей.
То есть каждая секунда записи у нас кодируется 22000 * 8 = 176000 битами.

21120000 / 176000 = 120 секунд.
0,0(0 оценок)
Ответ:
// PascalABC.NET 3.0, сборка 1076
type
  Point=record
  x,y:real
  end;
  Line=record
  A,B:Point
  end;
  Triangle=record
  A,B,C:Point;
  sa,sb,sc:real; { длины сторон }
  end;

procedure GetPoint(PointName:char; var M:Point);
begin
  Write('Введите координаты точки ',PointName,'(x,y): ');
  Read(M.x,M.y)
end;

function LineLength(A,B:Point):real;
begin
  LineLength:=sqrt(sqr(B.x-A.x)+sqr(B.y-A.y))
end;
 
procedure CreateTriangle(var T:Triangle; var l:boolean);
begin
  With T do begin
    GetPoint('A',A);
    GetPoint('B',B);
    GetPoint('C',C);
    sa:=LineLength(B,C);
    sb:=LineLength(A,C);
    sc:=LineLength(A,B);
    l:=(sa+sb>sc) and (sa+sc>sb) and (sb+sc>sa)
  end
end;

function TriangleIsLikes(T1,T2:Triangle):boolean;
var
  k1,k2,k3:real;
begin
  k1:=T1.sa/T2.sa; k2:=T1.sb/T2.sb;
  if k1=k2 then begin
    k3:=T1.sc/T2.sc;
    TriangleIsLikes:=k1=k3
    end
  else
    TriangleIsLikes:=False
end;

var
  T1,T2:Triangle;
  legal:boolean;
begin
  Writeln('*** Первый треугольник ***');
  CreateTriangle(T1,legal);
  if legal then begin
    Writeln('*** Второй треугольник ***');
    CreateTriangle(T2,legal);
    if legal then
      if TriangleIsLikes(T1,T2) then Writeln('Треугольники подобны')
      else Writeln('Треугольники не подобны')
    else Writeln('Треугольник невозможно построить')
    end
  else Writeln('Треугольник невозможно построить')
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота