МурррKsKs
13.04.2023 00:28

Напишите программу на языке паскаль которая выводит порядковый номер минимального элемента в двухмерном массиве

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
gek45
25.08.2020 09:50
//Pascal ABC.NET v3.0 сборка 1111

Const
 n=10;

Var
 ma:array[1..n,1..n] of integer;
 min,mini,minj,i,j:integer;
begin
min:=2147483647;
 randomize;
  writeln('Matrix:');
   for i:=1 to n do
   begin;
   writeln;
    for j:=1 to n do
     begin;
      ma[i,j]:=random(300);
      write(ma[i,j]:4);
      if min>ma[i,j] then
       begin;
        min:=ma[i,j];
        mini:=i;
        minj:=j;
       end;
     end;
   end;
 writeln;
 write('Строка:',mini,' столбец:',minj);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота