devochka0001
22.01.2021 18:55

Паскаль. Составить программу вывода элементов массива, которые меньше среднего арифметического.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vitashe135
18.06.2021 13:17
//Видимо, это одна задача, так как "изменения" во второй не указаны
//Pascal ABC.NET v3.1 сборка 1172

Const
 n=20;

Var
 ar:array[1..n] of integer;
 i:integer;
begin
 randomize;
 writeln('First array:');
  for i:=1 to n do
   begin
    ar[i]:=random(10)-3;
    write(ar[i]:4);
    if ar[i]>0 then ar[i]:=ar[i]*2 else ar[i]:=0;
   end;
 writeln;
 writeln('Final array:');
  for i:=1 to n do
   write(ar[i]:4);
end.

Пример работы программы:
First array:   2  -3   5   6  -3  -3   1  -2  -3   1   3  -3   4  -3   1  -1   6   6   2   3
Final array:   4   0  10  12   0   0   2   0   0   2   6   0   8   0   2   0  12  12   4   6
0,0(0 оценок)
Ответ:
razumova22
08.04.2023 15:17
1) А В  В(отр с черточкой)   В(отр)vA    F
    0  0  1                                   1        0
    0  1  0                                   0        0
    1  0  1                                   1        1
    1  1  0                                   1        1 

2)  ABC AVB CVB  F
     0 0 0  0       0     0
     0 0 1  0       1     0
     0 1 0  1       1     1  
     1 0 0  1       0     0
     0 1 1  1       1     1
     1 0 1  1       1     1
     1 1 0  1       1     1    
     1 1 1  1       1     1 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота