Rinako12
05.08.2021 02:13

Программирование на С++

Дан двумерный массив
целых чисел 7x7. Составить программу:

а) которая определяет, есть ли в некоторой строке массива хотя бы один элемент, равный заданному числу;
б) которая определяет, есть ли в некотором столбце массива хотя бы один элемент, кратный заданному числу.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Данил2007Г
14.10.2020 01:46

Для программы а удалите часть, выделенную комментарием "программа б"

Для программы б удалите часть, выделенную комментарием "программа а"

#include <iostream>

#include <iomanip>

#include <ctime>

int main()

{

int i,j, a, k;

int A[7][7];

setlocale(LC_ALL, "Russian");  // Русский язык в консоли

srand(time(0));

for (i = 0; i < 7; i++)

{

 for (j = 0; j < 7; j++)

 {

  A[i][j] = rand() % 100;

  std::cout << std::setw(5) << A[i][j];

 }

 std::cout << std::endl;

}

// Программа a

std::cout << "Введите строку и число через пробел: ";

std::cin >> k >> a;

for (j = 0; j < 7; j++)

 if (A[k-1][j] == a)

 {

  std::cout << "Есть";

  break;

 }

if (j==7) std::cout << "Нет";

// Программа a

// Программа б

std::cout << "Введите столбец и число через пробел: ";

std::cin >> k >> a;

for (i = 0; i < 7; i++)

 if (A[i][k-1] % a == 0)

 {

  std::cout << "Есть";

  break;

 }

if (i == 7) std::cout << "Нет";

// Программа б

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота