akolosov2002
01.09.2022 14:24

Напишите программу, в которой определяются координаты точки С (x,y), делящей отрезок AB
с координатами концов А(x1,y1) и В(x2,y2) на части таким образом, что AC=m*АВ (где 0 От пользователя требуется ввод координат точек А и В и коэффициента решить Паскале
Результат должен быть 3.2; 3.7

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
azik55
26.06.2021 07:45

#include <iostream>

using namespace std;

int main()

{

   int a;

   cin >> a;

   if (a > 0)

   {

       a += 1;

   }

   cout << a;

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

using namespace std;  // Пространство имен

int main()

{

   int a;  // Создание целочисленной переменной a

   cin >> a;  // Ввод значения переменной a с клавиатуры

   if (a > 0)  // Если значение переменной а > 0

   {

       a += 1;  // К переменной a прибавляем единицу

   }

   cout << a;  // Выводим значение переменной a

}

0,0(0 оценок)
Ответ:
0208
05.04.2020 16:18

Условие:

Даны два числа: a и b. Ваша программа должна поменять два числа местами, если a < b, после чего вывести их.

#include <iostream>

#include <clocale>

using namespace std;

int main()

{

   setlocale(LC_ALL,"Russian");

   int a, b;

   cout << "Введите a, b: ";

   cin >> a >> b;

   if (a < b)

   {

       swap(a, b);

   }

   cout << a << " " << b;

}

Объяснение:

#include <iostream>  // Библиотека ввода-вывода

#include <clocale>  // Библиотека для локализации (возможно, будет работать без нее)

using namespace std;  // Пространство имен

int main()

{

   setlocale(LC_ALL,"Russian");  // Локализация (возможно, будет работать без нее)

   int a, b;  // Создание целочисленных переменных

   cout << "Введите a, b: ";  // Вывод текста в консоль

   cin >> a >> b;  // Вводим с клавиатуры

   if (a < b)  // Если а < b

   {

       swap(a, b);  // Меняем a и b местами

   }

   cout << a << " " << b;  // Вывод а и b через пробел

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота