ЕхоBts97
05.07.2022 18:45

Составить блок схему и написать программу, которая находит сумму нечетных и количество четных делителей натурального числа.(31954)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vimeworldru
01.10.2020 18:30
Var n,i,k,s:integer;
begin
read (n);
k:=0;
s:=0;
for i:=1 to n do
begin
if (n mod i = 0) then
begin
if (i mod 2 = 0)then
begin
k:=k+1;
end else
begin
s:=s+i;
end;
end;
end;
writeln ('Кол-во чётных - ',k);
writeln ('Сумма нечётных - ',s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота