genЕsis
20.03.2023 00:17

с информатикой (8 класс программирование в PaskalABC)
1.Строчные английские буквы расположены в кодовой таблице символов в порядке своего следования в алфавите и имеют коды с 97 по 122. Написать программу, которая принимает на ввод одну из строчных букв английского алфавита, а возвращает её порядковый номер в алфавите и букву с тем же порядковым номером, но с конца.
Пример: Порядковый номер буквы d в английском алфавите – 4, буква с тем же порядковым номером, но с конца – w.
2.Написать программу, которая проверяет истинность высказывания о том, что введённое пользователем число х – целое.
Пример: при x = 7.74, значение истинности высказывания – false.
3.Написать программу, которая проверяет истинность высказывания о том, что слово из пяти букв, введённое пользователем, является палиндромом.
Палиндром – это слово которое читается одинаково как слева направо, так и наоборот.
Пример: при слове довод, значение истинности высказывания – true.
4.Найти наибольшее из двух чисел, введённых пользователем. Если числа равны между собой, вывести любое из них.
Пример: из чисел 75.2 и 65.1 наибольшее – 75.2.
5.3 отрезка заданы своими длинами. Определить, образуют ли эти отрезки треугольник, и если образуют, то какой: остроугольный, прямоугольный или тупоугольный.
(тут должны быть 3 треугольника)

Пример: отрезки с длинами равными 45, 11 и 60 не образуют треугольник.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
airflash1372
19.02.2022 19:29
// PascalABC.NET 3.2, сборка 1467 от 02.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Аргумент     Функция');
  var s:=0.0;
  var x:=0.5;
  var f:real;
  var b:=true;
  while x<=3 do begin
    if b then f:=sin(x) else f:=cos(x);
    Writeln(x:6:1,f:14:6);
    b:=not b; x:=x+0.5; s:=s+f
    end;
  Writeln('  Сумма',s:13:6)
end.

Результат
Аргумент     Функция
   0.5      0.479426
   1.0      0.540302
   1.5      0.997495
   2.0     -0.416147
   2.5      0.598472
   3.0     -0.989992
  Сумма     1.209556
0,0(0 оценок)
Ответ:
dxdarthur2001
24.08.2021 06:46

К первому поколению (англ. first-generation programming language, 1GL) относят машинные языки — языки программирования на уровне команд процессора конкретной машины. Для программирования не использовался транслятор, команды программы вводились непосредственно в машинном коде переключателями на передней панели машины. Такие языки были хороши для детального понимания функционирования конкретной машины, но сложны для изучения и решения прикладных задач.

Термины «первое поколение» и «второе поколение» были введены одновременно с термином «третье поколение». Фактически, эти термины в то время не использовались. С появлением языков высокого уровня, языки ассемблера стали относить к первому поколению языков.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота