magmadi1
14.01.2020 19:42

. В результате выполнения фрагмента программы:а:=20; b:=(a mod 10)*10; a:=(b*2)+a div 100; if a>b then c:=a+b else c:=b-a;переменная с примет значение: *​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
LiudaSerga2345
19.04.2020 18:11
Возможно, так, как сделал я - не совсем то, что хотел от вас преподаватель. Но программа работает как надо по вашему заданию. При чем вводить можно даже числа из девяти знаков

function checkstr( x: string ): boolean; // это функция, которая проверяет введенное пользователем на то, является ли это целым положительным числом, а не какими-нибудь буквами
begin
var k: integer;
if length(x) > 0 then begin
Result := True;
for k := 1 to length(x) do
if not (x[k] in ['0'..'9']) then begin
Result := False;  // если пользователь ничего не ввел или ввел не цифры, то будет возвращена ложь
end;end;end;

var N: string;
error, r, i, min: integer;
B: array[1..8] of integer; // В - массив, в котором будут храниться все цифры введенного числа
begin
write('Введите целое положительное число: ');
readln(N);
if checkstr(N) then begin // вызываем нашу функцию на обработку введенных данных
r := Length(N); // присваиваем переменной r размер введенной строки
val( N[ 1 ], min, error); // конвертирует строковое значение в тип integer и присваиваем минимальному значению первую цифру
for i := 2 to r do begin
val( N[ i ], B[ i ], error ); // конвертируем строковые цифры в integer
if ( B[i] < min ) AND ( B[i] mod 2 <> 0) then min := B[i]; // если цифра нечетная и меньше переменной min , то присвоить переменной min значение этой цифры
if ( min mod 2 = 0 ) then min := B[i]; // проверяем на всякий случай еще раз первую цифру
end;
if ( min mod 2 = 0 ) then writeln('Нечетных цифр нет') // если нечетных цифр нет, а наименьшая цифра четная, то говорим, что нечетных цифр нет
else writeln( 'Наименьшая нечетная цифра в числе: ', min ); // выводим наименьшую нечетную цифру из числа
end
else writeln('Неверный формат ввода'); // если пользователь вдруг ввел буквы или какие-нибудь каракули вместо целого числа
end.
0,0(0 оценок)
Ответ:
kudesnik72rusoz03b4
27.09.2020 20:15
Var N, i: integer; // N - переменная хранения количества чисел, которое введет пользователь
A: array[1..20] of integer; // массив, содержащий САМИ ЧИСЛА, которые введет пользователь 
begin
write('Сколько чисел вы собираетесь ввести? ');
readln(N); 
for i := 1 to N do begin
write('Введите ', i, ' число: '); // ввод чисел
readln( A[ i ] );
end;
write('Из них числа от 20 до 75, кратные 4: ');
for i := 1 to N do begin
if ( A[ i ] >= 20 ) and ( A[ i ] <= 75 ) then // проверяем в каком промежутке лежит число
if ( ( A[ i ] mod 4 ) = 0 ) then write( A[ i ], ' '); // если число меньше 75 и больше 20, тогда проверяем кратно ли оно четырем. Если да, то выводим его
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота