dmitrylazar1
05.07.2022 01:30

Сделайте информатику умоляю.Я вообще не разбираюсь.
Составить программу вычисления значений функции y = 2*x +1, на промежутке
[-3; 6] с шагом 2 и ответить на во а) сколько раз выполнится цикл
б) при каком значении х цикл выполнится последний раз
в) при каком значении х цикл прервётся
(Я вообще не разбираюсь но если что тема Цикл с заданным условием окончания работы и мы не изучали Паскаль только Бейсик изучали так что если надо чё то на языке этом писать то только БЕйсик)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ilmir123456789
02.01.2022 09:07
Program project1;
uses
crt,math;
var  s:real;  i,j,f:real;  a:integer;
begin 
writeln('vvedite 1 chislo ');readln(i);
  writeln('vvedite 2 chislo ');readln(j); 
 writeln('vvedite 3 chislo ');readln(f); 
 s:=i; 
 if j<s then s:=j; 
 if f<s then s:=f; 
 if s<0 then 
 begin  
  if i<0 then inc(a);  
  if j<0 then inc(a);  
  if f<0 then inc(a);  
  writeln('kolichestvo otricatelnix ',a:2);
  end 
 else  
begin  
  if i>0 then i:=i*-1;
  if j>0 then j:=i*-1;
  if f>0 then f:=i*-1; 
 end; 
 writeln('min chislo ',s:2:0); 
 readln;
end.     
0,0(0 оценок)
Ответ:
pogoreiko
29.08.2021 23:43
ответ: 4Объяснение:

Создаём массив из 11 элементов, который называем Dat:

целтаб Dat[1:11]

Объявляем переменные к и ш, являющимися целыми числами:

цел к, ш

Заполняем массив Dat:

Dat[1]:=21 Dat[4]:=19 Dat[7]:=23 Dat[10]:=29 Dat[2]:=23 Dat[5]:=25 Dat[8]:=21 Dat[11]:=19 Dat[3]:=20 Dat[6]:=22 Dat[9]:=22

Присваиваем переменной ш значение 0.

ш:=0

Объявляем цикл от 1 до 11, то бишь пробегаемся по массиву Dat и смотрим, если значение элемента больше 22, то прибавляем к переменной ш 1:

нц для к от 1 до 11 если Dat[к]>22  то    ш:=ш+1 Все кц

Выводим на экран значение переменной ш:

вывод ш

Таким образом мы видим, что программа подсчитывает количество классов в которых больше 22 учеников. Таких классов будет 4: 2(23), 5(25), 7(23) и 10(29).

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота