sukhovilopolina
20.03.2021 14:25

С клавиатуры вводится натуральное число. Составить программу проверяющую утверждение верно ли что цифра 7 встречается в числе более двух раз.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Мурад1001
04.06.2022 19:11

Я вот тоже Вышел порешать =).

var p: array [1..1000] of record

slovo:string;

k:integer;

end;

N,i,j,max:integer;

c:char;

a:array [97..122] of integer;

BEGIN

max:=0;

readln(N);

for i:=1 to N do

begin

p[i].slovo:='';

repeat

read(c);

p[i].slovo:=p[i].slovo+c

until c=' ';

readln(p[i].k);

for j:=1 to length(p[i].slovo) do

if (ord(p[i].slovo[j])>=97) and (ord(p[i].slovo[j])<=122) then

a[ord(p[i].slovo[j])]:=a[ord(p[i].slovo[j])]+p[i].k;

end;

for j:=97 to 122 do

if a[j]>max then

max:=a[j];

write(max);

end.

0,0(0 оценок)
Ответ:
Ира21fu
04.06.2022 19:11
1. Задача решается с стека (алгоритм Дейкстры для обработки обратной польской записи). Предполагается, что во вводимой строке содержится корректное выражение, удовлетворяющее условиям задания.

// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var w:=ReadlnString.ToWords;
  var St:=new Stack <integer>;
  var r:=0;
  foreach var t in w do
    if t[1].IsDigit then St.Push(t.ToInteger)
    else begin
      var a:=St.Pop;
      var b:=St.Pop;
      case t[1] of
      '+':St.Push(a+b);
      '-':St.Push(b-a);
      '*':St.Push(a*b)
      end;
    end;
  Writeln(St.Pop) 
end.

Контрольный пример
8 9 + 1 7 - *
-102

2. Задача крайне просто решается при регулярного выражения с рекурсией. Фактически вводить количество шаров не нужно, поэтому после ввода оно отбрасывается.

// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln(ReadlnString.ToWords.Skip(1).JoinIntoString('').
      MatchValue('(.)\1{2,}').Length);
end.

Контрольный пример
5 2 3 3 3 1
3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота