Написать программу печати чисел фибоначчи от 1 до 1000, являющихся простыми числами, а также их порядковых номеров в ряду фибоначчи. с программой на паскале .
Var f1,f2,s:longint; k:integer; function prost(n:longint):boolean; var j,m:integer; begin m:=0; for j:=2 to trunc(sqrt(n)) do if n mod j = 0 then inc(m); prost:=m=0; end; begin f1:=1; f2:=1; writeln('№ - Число'); writeln('1 - ',f1); s:=1; k:=2; while s<=1000 do begin if prost(s) then writeln(k,' - ',s); inc(k); s:=f1+f2; f1:=f2; f2:=s; end; end.