korotkovavd2006
17.09.2020 10:46

Используя программу Example2, составить программу заполнения массива из 25 чисел случайными значениями из диапазона – 20 до +20 и подсчитать количество отрицательных элементов

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ekaterinavarfo
04.05.2023 21:12

Часть программы. Решение задач

1. Найдите ошибку в программе:

program ;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

2. Найдите ошибку в программе:

program Prim 2 1;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f ); p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

3. Найдите ошибку в программе:

program Prim_2_1;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

4. Найдите ошибку в программе:

program Prim_2_1;

var a,b:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

5. Найдите ошибку в программе:

program Prim_2_1;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

6. Найдите ошибку в программе:

program Prim_2_1;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

writeln('p=',p);

readln

end.

7. Найдите ошибку в программе:

program Prim_2_1;

var a,b,c,d,f,p:integer;

writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

8. Следующий алгоритм в результате выполнения программы находит:

program Prim_2_3;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c;

writeln('p=',p);

readln

end

9. Найдите ошибку в программе:

program Prim_2_1;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p=:a+b+c+d+f;

writeln('p=',p);

readln

end.

0,0(0 оценок)
Ответ:
fivmif
18.02.2020 09:57

Жобалаудың барысын басқаруды жақсарту мақсатында әрбір кезең нақтыланады, яғни кезеңдерге бөлінеді.

Автоматтандырылған жүйені құрудың 4 кезеңі-Жұмыс сипаты, оның нәтижесі немесе орындаушылардың мамандануы бойынша анықталатын АЖ құру сатысының бір бөлігі.

АЖ құру кезеңдерінің мазмұны ГОСТ 34.601-90 1-қосымшасында регламенттелген.

"АС-қа қойылатын талаптарды қалыптастыру" 1-ші сатысында "объектіні тексеру және АС құру қажеттілігінің негіздемесі" 1-ші кезеңінде объект және оның қызметінің түрлері туралы деректер жинауды жүргізеді. Объектінің және оның құрамдас бөліктерінің жұмыс істеу сапасын бағалайды. Автоматтандыру құралдарының көмегімен шешуге болатын мәселелер мен міндеттерді анықтайды. Жүйені құрудың орындылығын бағалаудың техникалық-экономикалық, әлеуметтік және басқа да түрлерін береді.

"АС-қа пайдаланушылардың талаптарын қалыптастыру" 2-ші кезеңінде АС-қа қойылатын талаптарды қалыптастыру үшін бастапқы деректерді дайындайды, пайдаланушылардың талаптарын қалыптастырады және ресімдейді. Автоматтандыру объектісінің сипаттамасы, жүйені әзірлеуге, іске қосуға және пайдалануға рұқсат етілген шығындар, күтілетін нәтиже, жүйені құру және жұмыс істеу шарттары сияқты құжаттарды дайындайды .

3-ші кезеңде" орындалған жұмыс туралы есепті және жүйені (тактикалық-техникалық тапсырма — ТТТ) әзірлеуге өтінімді жасау " 1-ші кезеңде орындалған жұмыстар туралы есепті және ТТТ әзірлеуге өтінімді немесе мазмұны бойынша ұқсас басқа құжатты ресімдейді.

"АС тұжырымдамасын әзірлеу" 2-ші сатысында "объектіні зерделеу" 1-ші кезеңінде автоматтандыру объектісін егжей-тегжейлі зерделейді.

"Қажетті ғылыми-зерттеу жұмыстарын жүргізу" (ҒЗЖ) 2-кезеңінде пайдаланушылардың барлық талаптарын іске асыру мүмкіндігін бағалау және жолдарды іздестіруді орындайды, ҒЗЖ бойынша есептерді ресімдейді және бекітеді.

"АС тұжырымдамасының нұсқаларын әзірлеу және пайдаланушының талаптарын қанағаттандыратын АС тұжырымдамасының нұсқасын таңдау "3-кезеңінде АС тұжырымдамасының, оларды іске асыру жоспарлары мен ресурстарының баламалы нұсқаларын әзірлеуді, артықшылықтары мен кемшіліктерін бағалауды жүргізеді және бірнеше әзірленген оңтайлы нұсқадан таңдайды. Жүйені қабылдау тәртібі мен шарттарын, оның тиімділігін айқындайды.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота