Mimosa1233
10.06.2021 06:10

Написать программу на Паскале

1. Алгоритм вычисления абсолютной величины действительного числа.
алг вещ аbs (вещ x)
нач
если x >=0
то знач:=x
иначе знач:=-x
все
кон

2. Алгоритм нахождения максимальной из двух величин.
алг вещ max 2 (вещ а,b)
нач
если а >=b
то знач:= а
иначе знач:=b
все
кон

3. Алгоритм решения квадратного уравнения аx2+bx+с=0, где а,b,с – произвольные вещественные числа (а≠0)
алг КВУР (вещ а,b,с, вещ x1, x2, лит y)
арг а,b,с
рез x1, x2, y
нач
вещ D
D:= b2-4ас
если D<0
то y:= «нет решения»
иначе
y:= «есть решения»
x1:=(-b+√D)/2а
x2:=(-b-√D)/2а
все
кон

4. Алгоритм Евклида вычисления наибольшего общего делителя двух натуральных чисел.
алг вещ НОД (нат m,n)
нач
нат x, y
x:= m
y:= n
пока x≠y
нц
если x >y
то x:= x- y
иначе y:= y-x
все
кц

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
NBAH123
18.04.2021 13:58
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var a:=-1.32;
  var b:=1.49;
  var h:=0.11;
  var y1:=-14.0;
  var y2:=17.0;
  var k:=0;
  var x:=a;
  while x<=b do begin
    var y:=Tan(x);
    if (y>=y1) and (y<=y2) then begin
      Writeln('x=',x:5:2,'  y=',y:7:4);
      Inc(k)
      end;
    x+=h
    end;
  Writeln('Найдено значений: ',k)
end.

Результат
x=-1.32  y=-3.9033
x=-1.21  y=-2.6503
x=-1.10  y=-1.9648
x=-0.99  y=-1.5237
x=-0.88  y=-1.2097
x=-0.77  y=-0.9697
x=-0.66  y=-0.7761
x=-0.55  y=-0.6131
x=-0.44  y=-0.4708
x=-0.33  y=-0.3425
x=-0.22  y=-0.2236
x=-0.11  y=-0.1104
x= 0.00  y= 0.0000
x= 0.11  y= 0.1104
x= 0.22  y= 0.2236
x= 0.33  y= 0.3425
x= 0.44  y= 0.4708
x= 0.55  y= 0.6131
x= 0.66  y= 0.7761
x= 0.77  y= 0.9697
x= 0.88  y= 1.2097
x= 0.99  y= 1.5237
x= 1.10  y= 1.9648
x= 1.21  y= 2.6503
x= 1.32  y= 3.9033
x= 1.43  y= 7.0555
Найдено значений: 26
0,0(0 оценок)
Ответ:
Classica27725
02.03.2023 03:14

1)

a = input('Введите ваш пол (м/ж): ')

if a == 'м':

   print('Вам нужно пройти налево')

elif a == 'ж':

   print('Вам нужно пройти направо')

else:

   print('Ввод не распознан')

input('Введите enter для выхода.')

2)

f = input('Введите вашу фамилию: ')

n = input('Введите ваше имя: ')

o = input('Введите ваше отчество: ')

p1 = input('Введите серию паспорта: ')

p2 = input('Введите номер паспорта: ')

d = input('Введиет дату вылета: ')

t = input('Введите время вылета: ')

nr = input('Введите номер рейса: ')

kol = input('Введите кол-во билетов: ')

k = input('Введите класс обслеживания (эконом/стандарт/бизнес): ')

if k == 'эконом':

   s = 8500 * int(kol)

elif k == 'стандарт':

   s = 12000 * int(kol)

else:

   s = 15500 * int(kol)

print('Добрый день,', f , n)

print('Ваша дата и время вылета:', d + ',', t)

print('Ваш номер рейса:', nr)

print('Паспортные данные:', p1 + ',', p2)

print('Ваше количество билетов:', kol)

print('Общая стоимость:', s)

input('Введите enter для выхода.')

3)

a = input('Введите сообщение: ')

print('Длина вашего сообщения:', len(a))

print(round(len(a) * 0.4))

input('Введите enter для выхода.')

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота