ArkhamCity
02.09.2020 01:02

Программирование циклических алгоритмов 9 класс

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Buboschka
04.09.2020 09:39
Значит 2527= количество квартир * количество подъездов
2527 = n * m = 7 * 19 *19
Получается, что если подъездов 7, то в каждом 19 * 19 квартир, что отвечает 19 площадкам, и на каждой площадке в таком случае по 19 квартир.

Или может быть 19 подъездов, 7 этажей по 19 квартир на этаже

Или же 2527 = 7 * 361 * 1 = 133 * 19 * 1

133 подъезда, 1 этаж, на каждом этаже 19 квартир
361 подъезд, 1 этаж, на каждом этаже 7 квартир
 
Или же 2527 = 2527 * 1 * 1

2527 подъезд, 1 этаж, на каждом этаже по 1 квартире
1 подъезд, 1 этаж, 2527 квартир на этаже

ответ: 1, 7, 19, 133, 361, 2527
0,0(0 оценок)
Ответ:
HiDolr
08.09.2020 04:05

program z1;//имя программы

var a:real;b,c,d:integer;//объявление глобальных переменных

function M (x,y:integer): integer;//название функции, параметры, тип результата

begin//тело функции

if x>y then M:=x else M:=y//неполный условный оператор

end;

begin//тело программы

read (a,b);//ввод значений переменных

if frac(a) >= 0.5 then c:=trunc(a)+1 else c:=trunc(a);//математическое округление

d:= M (b,c);//вызов функции

write(d)//вывод результата

end.

Объяснение:

картинка 1 - блок-схема программы

картинка 2 - блок-схема функции

математическое округление, чтобы 2,5 было равно 3, а не 2 как при использовании функции round


Вводится два числа: первое вещественного типа а второе – целого. Написать программу поиска максимума
Вводится два числа: первое вещественного типа а второе – целого. Написать программу поиска максимума
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота