Мойурок
15.03.2021 12:27

Написать программу Pascal. Найти простые числа х и у, которые в произведении дают число z, типа longint.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
янннак
23.12.2021 06:00

число Z вводится

Pascal

var

 i, z: longint;

begin

 write('Введите Z : ');

 readln(z);

 for i:=1 to trunc(sqrt(z)) do begin

   if z mod i = 0 then

     writeln(i, ' * ', z/i);

 end;  

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота