xennika
25.02.2023 01:02

2) Напишите программу, которая вычисляет произведение четырех чисел, введенную в форме символьной строки. Все числа целые.
3) Введите с клавиатуры символьную строку, найдите самое короткое слово и определите, сколько в ней слов.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
prozorovamary23
19.11.2020 14:32

#include <bits/stdc++.h>

using namespace std;

long long a,b,c,A,B,count1=0,d,F[17],sum=0,min1=10000,minI;

int main()

{

   for(int i=1;i<=10;i++){

       F[i]=rand()%30;

       if(F[i]>15){

           F[i]=F[i]/3;

       }

       if(F[i]<min1){

           min1=F[i];

           minI=i;

       }

       sum+=F[i];

       cout<<F[i]<<" ";

   }

   cout<<endl;

   cout<<"Suma: "<<sum<<endl;

   cout<<"minIndex: "<<minI<<endl;

   return 0;

}

11 5 4 10 9 4 6 6 7 14

Suma: 76

minIndex: 3

Объяснение:

Тут и так всё понятно


1. Заполнить массив из 10 элементов целыми случайными числами, лежащими в диапазоне от 0 до +30.2. В
0,0(0 оценок)
Ответ:
spritemax11
22.09.2020 07:53

program cifry;

var p: integer;

var c: integer;

var s: integer;

var d: byte;

BEGIN

writeln('Программа расчёта разности произведения и суммы цифр трёхзначного числа.');

c:=100+random (900);

writeln('Число -', c);

p:=1;

s:=0;

d:=c mod 10;

s:=s+d;

p:=p*d;

c:=c div 10;

d:=c mod 10;

s:=s+d;

p:=p*d;

c:=c div 10;

d:=c mod 10;

s:=s+d;

p:=p*d;

c:=c div 10;

write('Разность произведения и суммы цифр числа -', p-s);

end.

Объяснение:

Нуэно ставить ";"  + переменная var

var p:integer, Нужно запускать програму и останавливать BEGIN , end. write писать в одной строке!

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота