Fuvhrcsghinm
11.01.2021 23:39

Напишите программу:Вводится предложение, заканчивающееся точкой. Между словами по одному пробелу. Подсчитать количество слов.Пример: Вход: ddd ooo ftftft. Выход: 3

с++.char

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nastafil30
28.07.2022 10:39
Var x, temp, p, a, original: integer;
found: boolean;
begin
found:=false; //переменная примет значение "истина" тогда, когда число А будет найдено в цифрах первого числа
writeln('Введите натуральное число");
Readln(original);
Writeln('Введите число A');
Readln(a);
x:=original;
p:=1; //будет хранить произведение цифр числа(если приравнять нулю, то произведение всегда будет равно нулю)
while x>0 do            //пока X болльше нуля
  begin
    temp:=x mod 10;     //заносим последнюю цифру числа X в переменную temp
    if temp=a then found:=true; //если цифра числа равна A, то помечаем, что нашли ее
    p:=p*temp;          //домножаем произведение на цифру
    x:=x div 10;        //отбрасываем последнюю цифру числа через целочисленное деление
  end;
Writeln('Произведение цифр числа ' + original + ' равно ' + p);
if found then writeln('Цифра' + a + ' есть в исходном числе ' + original)
else writeln('Цифра ' + a + ' отсутствует в оригинальном числе ' + original)
end;
0,0(0 оценок)
Ответ:
milasha24
07.10.2021 13:56
Sub Calculate()
Dim coll As Collection
Dim i As Integer
Dim sum As Double
Dim negative As Integer
Dim composition As Integer
negative = 0
composition = 1
Set coll = New Collection
sum = 0
n = CInt(InputBox("Введите количество чисел", "Ввод", "", 2000, 2000))
For i = 1 To n
elmnt = CInt(InputBox(i & " число", "Ввод", "", 2000, 2000))
coll.Add elmnt
sum = sum + elmnt
Next i

For i = 1 To coll.Count
If (coll.Item(i) < 0) Then
negative = negative + 1
End If
If (coll.Item(i) Mod 2 = 1) Then
composition = composition * coll.Item(i)
End If
Next i
MsgBox "Количество отрицательных = " & negative & vbCrLf & "Произведение нечетных = " & composition & vbCrLf, vbOKOnly, "Результаты"
End Sub
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота