Ониг
15.05.2022 08:00

написать программу на языке С#. Дан массив размером nxm, элементы которого целые числа. Подсчитать среднее арифметическое четных элементов, расположенных ниже главной диагонали.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Микарусский
02.12.2020 17:59

на локальных тестах работает

Объяснение:

using System;

class Program

{

   static int P(string p)

   {

       int a = 0, dec = 1;

       for (int i = p.Length - 1; i >= 0; i--)

       {

           a += (p[i] - '0') * dec;

           dec *= 10;

       }

       return a;

   }

   static void Main(string[] args)

   {

       int n = int.Parse(Console.ReadLine());

       int m = int.Parse(Console.ReadLine());

       int c = 0, sum = 0;

       for (int i = 0; i < n; i++)

       {

           int nowSum = 0;

           string a = Console.ReadLine();

           string[] now = a.Split(' ');

           for (int j = 0; j < i; j++)

           {

               int num = P(now[j]);

               if (num % 2 == 0)

               {

                   c++;

                   sum += num;

               }

           }

       }

       Console.WriteLine(sum / c);

       Console.ReadLine();

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота