оркп
05.09.2022 08:02

ЯЗЫК PYTHON
1.
Используя полное ветвление, у следующий фрагмент программы:
if a > b: c = 1
if a > b: d = 2
if a <= b: c = 3
if a <= b: d = 4
2.
Имеются данные о количестве полных лет трёх призёров спартакиады.
Напишите программу, выбирающую и выводящую возраст самого младшего призёра.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Илья11345
03.08.2020 07:28

1.

составной оператор - это скобки begin...end (в С образных языках для это используются реальные скобки {}) которые позволяют объединить несколько команд под одним оператором

if a > b then begin

   с:=1;

   d:=2;

end

else begin

   c:=3;

   d:=4;

end

2.

var

    a,b,c,max:integer;

begin

   writeln('Введите возраст призеров:');

   readln(a,b,c);

   if (a < b) and (a < c) then

   begin

       max := a;

       writeln('Самый младший - первый призер, ему ',max,' лет.');

   end;

   if (b < a) and (b < c) then

   begin

       max := b;

       writeln('Самый младший - второй призер, ему ',max,' лет.');

   end;

   if (c < a) and (c < b) then

   begin

       max := c;

       writeln('Самый младший - третий призер, ему ',max,' лет.');

   end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота