Cociheyuajnqhvedoxbs
16.11.2022 21:26

Представленный ниже на пяти языках программирования фрагмент
программы обрабатывает элементы одномерного целочисленного массива A
с индексами от 0 до 10. Перед началом выполнения данного фрагмента эти
элементы массива имели значения 4, 5, 6, 4, 3, 2, 14, 16, 2, 3, 7 (т.е. A[0] = 4,
A[1] = 5, …, A[10] = 7). Определите значение переменной s после выполнения
фрагмента s := 0;
for k:=1 to 9 do begin
if A[k-1] < A[k+1] then begin
t := A[k-1];
A[k-1] := A[k+1];
A[k+1] := t;
s := s + A[k]
end
end;

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
karinakarim
02.01.2023 13:44

1) Не достаточно информации

2)

Program help1;
Uses Crt;
Var a : Array[1..3, 1..3] of Integer;
i, j, m : Integer;

Begin
ClrScr;

For i := 1 to 3 do
For j := 1 to 3 do
Begin
Write('Введи a[', i, ', ', j, ']: ');
Readln(a[i, j]);
End;

If a[1, 1] > 0 then
m := 4;
If a[1, 1] < 0 then
m := 7;

For i := 1 to 3 do
For j := 1 to 3 do
a[i, j] := a[i, j] * m;
End.

3)

Program help2;
Uses Crt;
Var s : String;
n, i : Byte;

Begin
ClrScr;

Write('Введи строку: ');
Readln(s);

n := 0;

For i := 1 to Length(s) do
if s[i] = '5' then
inc(n);

Write('Цифра 5 встречается ', n, ' раз');
End.

0,0(0 оценок)
Ответ:
Айка12341
16.01.2021 01:31
Задание№ 1№ 2№ 3№ 4№ 5ответААГГАТестовое задание№ 6№ 7№ 8№ 9№ 10ответГВБГГ

ответы на открытие вопросы

ответ на вопрос 1:
Число перебора столь мало, что можно просто выписать всевозможные комбинации: ЗА, ЗД, ЗЧ, ДА, ДЗ, ДЧ, ЧА, ЧЗ, ЧД, АА, АЗ, АД, АЧ.
Всего

ответ на вопрос 2:
Тяжелая атлетика
Из первого условия тяжелоатлет не Сережа, из второго — не Коля, из третьего — не Петя. Значит, он — Вася.

ответ на вопрос 3:
Зашифрованы последовательно слова ноутбук, компьютер, модем, корова, мышь.
Лишнее слово — корова.

ответ на вопрос 4:
78
1+2+3+4+5+6+7+8+9+10+11+12=78.

ответ на вопрос 5:
Первым
Катя стоит до Лизы, до Феди, и, значит, до Ромы. То есть Катя стоит первой или второй. Поскольку она не первая, то – вторая, а остальные, кроме Андрея, за ней. Андрей – первы
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота