Аннапомогите
27.09.2020 06:08

Напишите программу к . найти количество отрицательных чисел, вводить пока не будет 3.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
shm06
08.10.2020 14:39
1) Программа будет запрашивать ввод новых чисел, пока он не введёт число 3:

var i,count,n: Integer;
begin
while i<>3 do
begin
writeln('Введите число');
readln(n);
if n<0 then inc(count);
i:=n;
end;
writeln('Кол-во: ',count);
end.

2) Программа будет запрашивать ввод чисел, пока отрицательные числа в сумме не будут равны числу 3:

var count,n: Integer;
begin
while count<>3 do
begin
writeln('Введите число');
readln(n);
if n<0 then inc(count);
end;
writeln('Кол-во: ',count);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота