Аня3885
19.12.2020 15:02

Написать программу нахождения суммы 3 случайных чисел и вывести на экран ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
jdjsjsjsj
17.02.2020 10:18
Вычислим остатки от деления обоих чисел на 9, для этого заметив, что у числа 10a + c такой же остаток, что и у a + c. Тогда можно, считывая цифру за цифрой, получить остаток для всего числа. Дальше проверяем, чем равно произведение остатков: если делится на 9, то произведение делится на 9, иначе не делится.

function mod9(f: text): integer;
var
  c: char;
  rem: integer;
begin
  rem := 0;
  while not eoln(f) do
  begin
    read(f, c);
    rem := (rem + ord(c) - ord('0')) mod 9;
  end;
  readln(f);
  mod9 := rem;
end;
 
var
  f: text;
  a: integer;
 
begin
  assign(f, 'input.txt');
  reset(f);
  a := mod9(f) * mod9(f);
  close(f);
  assign(f, 'output.txt');
  rewrite(f);
  writeln(f, a);
  if a mod 9 = 0 then
    write(f, 'YES')
  else
    write(f, 'NO');
  close(f);
end.
0,0(0 оценок)
Ответ:
Milki0Way0
23.12.2020 08:40
@ впервые показали в начале 15 века. Испанские купцы пользовались таким знаком для обмеривания товара. Мера использовалась при покупке скота или вина,это своеобразное сокращение от " arroba",полного названия этой меры. Дальше этот знак использовался в качестве ценника ,а также,пометки для отчётов бухгалтеров. Только после столь длительного пути,этот знак оказался на наших клавиатурах. Рэй Томлинсон стал первым кто сумел отправить настоящее электронное письмо. Электронные коммуникации начали своё развитие именно в тот момент, когда письмо передали между компьютерами-это и было первый e-mail.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота