Али20061111
05.05.2021 01:24

Даны два одинаковых массив из 5 целых чисел заданных случайно от 0 до 30. A и B. найти их скалярное произведение. Скалярное произведение двух массивов одинаковой разностью считается сумма произведений соответствующих элементов​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
hhhhyd
31.10.2020 02:28

1. В цветовой модели RGB для кодирования одного пикселя используется 3 байта. Фотографию размером 2048x1536 пикселей сохранили в виде несжатого файла с использованием RGB-кодирования. Определите размер получившегося файла.    

Дано:                       Решение:

х*у=2048*1536       V= x*y*i=2048*1536*3байта= 9437184 байта=9216 Кбайт = 9 Мбайт

i=3 байта  

V – ?

2. Для хранения растрового изображения размером 128*128 пикселей отвели 4 килобайта памяти. Каково максимально возможное число цветов в палитре изображения?

Решение: i=V/x*y=4*1024*8/(128*128)=2  N=4

3. Укажите минимальный объем памяти (в килобайтах), достаточный для хранения любого растрового изображения размером 64*64 пикселя, если известно, что в изображении используется палитра из 256 цветов. Саму палитру хранить не нужно.

V= 64*64*8=32768 бит = 4096 байт = 4 Кбайт

ответ: 4 Кбайт

4. Для хранения растрового изображения размером 64*64 пикселя отвели 512 байтов памяти. Каково максимально возможное число цветов в палитре изображения?

Дано:                      Решение:

х*у= 64*64             V=x*y*i;      i=V/(x*y)=512*8 бит/(64*64)= 4096 бит/4096=1бит

V= 512 байтов        N=2i =2

Объяснение:

0,0(0 оценок)
Ответ:
Samiko280106
08.03.2020 03:17
Const
  n = 20;

var
  T: array[1..n] of integer;
  i, k: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  k := 0;
  for i := 1 to n do
  begin
    T[i] := Random(11)-5;
    Write(T[i]:3);
    if ((i mod 2)<>0) and (T[i]=0) then Inc(k);
  end;
  Writeln;
  Writeln('Количество нулевых элементов на нечетных местах равно ',k);
end.

Тестовое решение:
Элементы массива
  2  5 -4  4  3 -2  5 -5 -1 -2  5  2  0 -5 -5 -4 -3  3  0  1
Количество нулевых элементов на нечетных местах равно 2

const
  n = 18;

var
  T: array[1..n] of integer;
  i: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  for i := 1 to n do
  begin
    T[i] := Random(51)-25;
    Write(T[i]:4);
  end;
  Writeln;
  Writeln('Результат');
  for i := 1 to n do
  begin
    if ((i mod 2)<>0) then T[i] := 0;
    Write(T[i]:4);
  end;
  Writeln;
end.

Тестовое решение:
Элементы массива
  23  -6   8  14  15  12 -24  20 -11  -7   4 -24  22 -19  12  -6  21  17
Результат
   0  -6   0  14   0  12   0  20   0  -7   0 -24   0 -19   0  -6   0  17
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота