Djilsi
17.08.2022 10:43

Наберите в текстовом файле с расширением docx программы на Питоне, решающие следующие задачи:

Задача 1. За с клавиатуры длины диагоналей ромба. Написать программу, вычисляющую площадь ромба.
Задача 2. Продаются товары двух видов. За с клавиатуры для каждого вида товаров цену, количество в начале рабочего дня и количество проданного товара. Вывести стоимость всех товаров в начале рабочего дня и стоимость всех непроданных товаров.
Задача 3. Занятия в школе начинаются в 8-10. Урок длится 40 минут, перемены длятся 15 минут. Написать программу, которая получает с клавиатуры номер урока и выводит время его начала

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
zska25
23.11.2022 19:30
Задачка в один оператор)))

// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
begin
  Writeln(ArrRandom(10,1,99).Println.Where(x->x mod 2=0).Average)
end.

Тестовое решение:
96 42 79 85 16 22 50 62 54 40
47.75

"Школьный подход" (видимо, короткому решению у нас не учат)

// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
const
  n=10;
var
  a:array[1..n] of integer;
  i,k,s:integer;
begin
  s:=0;
  k:=0;
  Randomize;
  for i:=1 to n do begin
    a[i]:=Random(99)+1;
    Write(a[i],' ');
    if a[i] mod 2 = 0 then begin
      s:=s+a[i];
      Inc(k)
      end
    end;
  Writeln;
  Writeln(s/k)
end.

Тестовое решение:
22 22 58 41 54 80 71 65 47 99
47.2
0,0(0 оценок)
Ответ:
никак45
16.07.2022 11:01
Var matrix1:array [,] of real; n:integer; tmp:real;
begin
  write('Введи размерность матрицы:');
  readln(n);
  matrix1:=new real[n,n];
  for var i:=0 to n-1 do  begin
    for var j:=0 to n-1 do
    begin
      matrix1[i,j]:=Random(100);
      write(matrix1[i,j]:4);
    end;
    writeln;
  end;
  writeln('Поменяли:');
  for var j:=0 to n-1 do
  begin
      tmp:=matrix1[j,n-1];
      matrix1[j,n-1]:=matrix1[n-1,j];
      matrix1[n-1,j]:=tmp;
  end;
  for var i:=0 to n-1 do begin
       for var j:=0 to n-1 do
            write(matrix1[i,j]:4);
       writeln;
  end;
 end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота