anjutaboyycova
26.08.2020 08:15

Очень нужна до завтра. Буду очень благодарна.

1) Дан целочисленный массив из n элементов. Элементы массива могут принимать значения от –1000 до 1000 (такие числа будет вводить пользователь, это проверять не нужно). Напишите программу, которая находит и выводит среднее арифметическое всех элементов массива, оканчивающихся на 12. Гарантируется, что хотя бы один такой элемент в массиве есть.

2) Дан целочисленный массив из n элементов. Элементы массива могут принимать целые значения от 0 до 10 000 включительно (такие числа будет вводить пользователь, это проверять не нужно). Напишите программу, которая находит максимальный из оканчивающихся на 3 элементов массива, затем увеличивает все элементы массива, кратные 8, на значение этого элемента, и выводит в строку. Если в массиве нет оканчивающихся на 3 элементов, он остаётся без изменений. Например, из массива
7, 23, 18, 24, 33, 48, 80
программа должна получить массив
7, 23, 18, 57, 33, 81, 113

3) Дан целочисленный массив из n элементов. Элементы массива могут принимать целые положительные значения от 1 до 10 000 включительно (такие числа будет вводить пользователь, это проверять не нужно). Напишите программу, которая находит разность максимального из чётных элементов массива, оканчивающихся на 2 и минимального из нечётных элементов массива, оканчивающихся на 5, затем уменьшает все элементы массива, которые больше этой разности, на величину этой разности, и выводит изменённый массив в обратном порядке в одну строку.
34, 22, 17, 42, 25, 10, 15, 45
программа должна получить массив
7, 22, 17, 15, 25, 10, 15, 18
и вывести:
18, 15, 10, 25, 15, 17, 22, 7

Заранее

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Tolik200611
29.03.2023 21:09
C#
3:
using System.IO;
using System;

namespace тылпыа
{
    class Program
    {
        public static void Main(string[] args)
        {
            StreamReader reader = new StreamReader("input.txt");
            StreamWriter writer = new StreamWriter("output.txt");
            string input = " ";
            while (true) {
                input = reader.ReadLine();
                if (input == null) {
                    break;
                }
                writer.WriteLine(input.Replace(", короче,", ", в общем,"));
            }
            writer.Close();
        }
    }
}
0,0(0 оценок)
Ответ:
KarinochkaShiну
17.05.2023 07:19
Const N = 30; // Количетсво дней
var
i,count:integer;
h: array [1..N] of integer;
begin
count:=0;
writeln('Введите количество осадков');
for i:=1 to N do
read(h[i]);
for i:=1 to N do
if h[i]>0 then
count:=count+1;
writeln('Количество дождливых дней ', count)
end.

В первой строке указываем количество дней. Это константа N
Далее объявляем, что переменная count равна 0. В этой переменной мы будем хранить количество дней с осадками.
Далее мы вводим с клавиатуры 30 чисел, показывающих осадки.
Потом мы проверяем, если число в массиве больше нуля, то мы увеличиваем count на единицу. Тоесть прибавляем +1 день с осадками.
В конце выводим количество дней с осадками
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота