jroslov
23.08.2022 00:52

2. Составьте программу для следующей задачи:
На вашей банковской карте Х рублей. Вы совершаете покупку на сумму В руб. Хватит ли имеющейся суммы расплатится за покупку? Если суммы достаточно, то вычислите остаток денег на карте после совершения покупки.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
xalva123
23.11.2022 02:55

Program asd;

uses crt;

var a,b,c,max:integer; r:real;

begin

 Write('Введите число A: '); 

Readln(a);

 Write('Введите число B: '); 

Readln(b); 

Write('Введите число C: '); 

Readln(c); 

If  a>=b then max:=a

 else 

 max:=b;   

 If c>max then

max:=c; 

r:=a+b+c;

 If (A>B) and (B>C) and (C>0) then

 Writeln('A= ',a*2,' B= ',b*2,' C= ',c*2);

 If (A<0) and  (B<0) and (C<0) and (A<>B) and (B<>C) and (C<>A)  then

 begin   

A:=max;   

 B:=max; 

 C:=max; 

Writeln('A= ',a,' B= ',b,' C= ',c); 

  end   

else   

 Writeln('Symma: ',r);

end

Объяснение:

Program asd;

uses crt;

var a,b,c,max:integer; r:real;

begin

 Write('Введите число A: '); 

Readln(a);

 Write('Введите число B: '); 

Readln(b); 

Write('Введите число C: '); 

Readln(c); 

If  a>=b then max:=a

 else 

 max:=b;   

 If c>max then

max:=c; 

r:=a+b+c;

 If (A>B) and (B>C) and (C>0) then

 Writeln('A= ',a*2,' B= ',b*2,' C= ',c*2);

 If (A<0) and  (B<0) and (C<0) and (A<>B) and (B<>C) and (C<>A)  then

 begin   

A:=max;   

 B:=max; 

 C:=max; 

Writeln('A= ',a,' B= ',b,' C= ',c); 

  end   

else   

 Writeln('Symma: ',r);

end

0,0(0 оценок)
Ответ:
oipoop54
13.11.2022 08:15

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')  

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')

print('Это действие будет повторяться 10 раз!')

Объяснение:

Команда print отвечает за вывод текста, итого текст будет выводиться 10 раз

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота