728099
15.07.2022 16:54

Составьте программу, позволяющую определить, являются ли числа a,b,c, пифагоровыми тройками.указанные числа a,b,c, являются пифагоровыми тройками, если квадрат одного из чисел равен сумме квадратов двух других.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Дарья290705
19.07.2020 19:24
Program pifThi;
var
 a,b,c:integer;
begin
 readln(a,b,c);
 if (sqr(a)=sqr(c)+sqr(b)) or 
    (sqr(b)=sqr(a)+sqr(c)) or
    (sqr(c)=sqr(a)+sqr(b)) then write('Yes!')
 else write('No!'); readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота