sluvka123123
25.03.2020 08:13

В паскале авс.
Напишите программу, которая в последовательности натуральных чисел определяет количество четных чисел. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Mira12202
31.05.2022 21:07

ответ на Pascal:

const N = 15;

var a: Array[1..N] of integer;

   i,j,k: integer;

begin

   for i := 1 to N do begin

       a[i] := random(-66) + 50;

       write(a[i],' ');

   end;

   writeln();

   j := N-1;

   while j > 0 do begin

       for i := 1 to j do begin

           if a[i] < a[i+1] then begin

               k := a[i];

               a[i] := a[i+1];

               a[i+1] := k;

           end;

       end;

       j := j-1;

   end;

   for i := 1 to N do begin

       write(a[i],' ');

   end;

end.

ответ на Python:

from random import randint

n = 15

a = [randint(-15,50) for i in range(n)]

print(a)

for j in range(n-1, 0, -1):

 for i in range(j):

   if a[i] < a[i+1]:

     k = a[i]

     a[i] = a[i+1]

     a[i+1] = k

print(a)

0,0(0 оценок)
Ответ:
кристина2059
15.03.2020 05:01

1.Алгоритми́ческий язык — формальный язык, используемый для записи, реализации или изучения алгоритмов. ... Неимперативные языки программирования на алгоритмический язык не выражаются, или выражаются неоднозначно.

2.Главная цель использования псевдокода — обеспечить понимание алгоритма человеком, сделать описание более воспринимаемым, чем исходный код на языке программирования. Псевдокод широко используется в учебниках и научно-технических публикациях, а также на начальных стадиях разработки компьютерных программ.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота