valeriehunt
22.09.2021 01:46

с информатикой
Нужно написать программу в Паскале


Котенок Васька влез на дерево высотой H метров. Какой длины Вам потребуется лестница, чтобы
достать Ваську с дерева. Учтите, что вокруг дерева имеется клумба диаметром A метра и цветы на
клумбе мять нельзя.
Входные данные
Во входном потоке в единственной строке через пробел записаны два вещественных числа H и A (0 < A,
B, C <= 100).
Выходные данные
В выходной поток следует в единственной строке записать вещественное число — длину лестницы, с
точностью до двух знаков после запятой.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ivanperepelkin
11.01.2020 11:24
#include <iostream>
#include <cstdlib>
#include <vector>
using namespace std;

int main()
{
vector<int> v;
cout <<"Укажите размер массива: ";
int s;
cin >>s;
srand(time(0));
for(int i=0; i!=s; ++i)
v.push_back(rand()%100);
int find;
cout <<"Введите число для поиска: ";
cin >>find;
bool founded = false;
for(auto it=v.begin(); it!=v.end(); ++it)
if(*it==find) founded=true;
if(founded)
cout <<"Это число есть в массиве!" <<endl;
else cout <<"Такого числа нет в мвссиве!" <<endl;

return 0;
}
0,0(0 оценок)
Ответ:
Alevtinka28
24.06.2022 12:21
1. Если имеется в виду язык Pascal, то получим следующее:
var: a;
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
begin
  readln(a);
  b:=a+a;
  writeln (b);
end.

Program50.pas(5) : Неизвестное имя 'b'

2. Попробуем такой вариант на Python

a =int(input())
b = a+a
print(b)

При вводе а получим на выходе 10

Получается, что в Pacal требуется объявлять переменные в секции переменных, или в любом месте программы можно объявить переменную с служебного слова var для PascalABC.net. Первый код можно переписать так, и он будет работать:

var: a;
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
begin
  readln(a);
  var b:=a+a;
  writeln (b);
end.

Рузультат при введенном значении 5 равен 10
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота