karinaandreevozb5ha
24.02.2021 17:36

Задание 1.

Написать код программы на Паскале для решения задачи.

Дан прямоугольный треугольник. В треугольнике высота, которая опущена из вершины прямого угла, равна 12 см, а один из катетов равен 24 см. Найти длину гипотенузы треугольника.

На проверку нужно прислать скриншот с кодом программы на Паскале и результаты работы.

Задание 2.

Написать программу на Паскале, в которой переменной Y присваивается значение наименьшей из четырех величин A, B, C и D. Входные данные задать с оператора ввода с клавиатуры.

На проверку нужно прислать скриншот с кодом программы на Паскале и результаты работы.

Задание 3.

Написать программу на Паскале для решения задачи.

Найти сумму n элементов следующего ряда чисел:

50, 45, 40, 35, 30…

Количество элементов (n) ввести с клавиатуры.

На проверку нужно прислать скриншот с кодом программы на Паскале и результаты работы.

Задание 4.

Написать программу на Паскале для решения задачи.

Вычислить произведение модулей элементов одномерного массива из 20 чисел, расположенных после первого отрицательного элемента. Входные данные задать самостоятельно.

На проверку нужно прислать скриншот с кодом программы на Паскале и результаты работы.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Юлясруля
19.12.2022 23:47
// ConsoleApplication60.cpp: определяет точку входа для консольного приложения.//
#include "stdafx.h"#include<conio.h>#include"iostream"#include "stdio.h"#include "time.h"
using namespace std;
int main(){ int x, y,c; setlocale(LC_ALL, "RUS"); srand((unsigned)time(NULL)); x = rand() % 8 + 2; y = rand() % 8 + 2; cout << "Сколько будет  " << x << "*" << y << "?" << "\n"; cout << "Введите ответ и нажмите Enter  "; cin >> c; if (x*y == c) { cout << "Правильно\n";  } else { cout << "Вы ошиблись   " << x << "*" << y << "=" << c;  }return 0;}
0,0(0 оценок)
Ответ:
oksanavolkova3
16.03.2023 05:54

Операционной системой называется целый ряд управляющих программ, которые используются в качестве интерфейса между компонентами ПК и обеспечивают наиболее эффективную реализацию ресурсов ЭВМ. Операционная система является основой системной программы, загружаемой при включении питания компьютера.

К основным функциям ОС относятся:

• получение от пользователя ПК команд или заданий;

• принятие и применение программных запросов на запуск и остановку других программ;

• загрузка в ОП подходящих для исполнения программ;

• защита программ от взаимного действия друг на друга, обеспечение сохранности данных и др.

По видам пользовательского интерфейса (набору приемов, обеспечивающих взаимодействие пользователей ПК с его приложениями) различают следующие ОС:

а) командный интерфейс – выдача на экран монитора системного приглашения для ввода команд с клавиатуры (например, ОС MS-DOS);

б) интерфейс WIMP (или графический интерфейс – графическое представление образов, которые хранятся на жестком диске (например, ОС Windows различных версий);

в) интерфейс SILK (Speech Image Language Knowledge) – использование речевых команд для взаимодействия пользователя ПК и приложений. Данная разновидность ОС в настоящий момент находится в стадии своего развития.

Согласно режиму обработки задач выделяют следующие ОС:

а) обеспечивающие однопрограммный режим, т. е организации вычислений, при котором в один момент времени они выполнять только одну задачу (например, MS-DOS);

б) работающие в мультипрограммном режиме, когда при организации вычисленией на однопроцессорной машине создается видимость выполнения нескольких программ.

Отличие между мультипрограммным и мультизадачным режимами состоит в том, что в мультипрограммном режиме происходит параллельное выполнение нескольких приложений, при этом пользователю не нужно заботиться об организации их работы, данные функции на себя берет ОС. При мультизадачном режиме параллельное выполнение и взаимодействие приложений должны обеспечивать прикладные программисты.

В соответствии с поддержкой многопользовательского режима ОС подразделяют:

а) на однопользовательские (MS-DOS, ранние версии Windows и OS/2);

б) многопользовательские (сетевые) (Windows NT, Windows 2000, Unix).

Основным отличием многопользовательских ОС от однопользовательских ОС является наличие средств защиты информации каждого пользователя от незаконного доступа других пользователей.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота