Фприт
27.08.2020 02:50

Написать программу запрашивающую число если введённое число положительное нужно вывести его квадрат в ином случаее его куб
Язык:Паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nikitakozlav8niks
16.10.2021 16:59
{ ответ дан на языке Pascal }
{         Вариант a         }
PROGRAM Solution(INPUT, OUTPUT);

VAR
  Str: STRING;
  Str1: STRING;
  Str2: STRING;
  Str3: STRING;
  TempStr: STRING;

BEGIN
  WRITE('Введите строку: ');
  READLN(Str);
  Str1 := COPY(Str, 1, LENGTH(STR) DIV 3);
  Str2 := COPY(Str, LENGTH(STR) DIV 3 + 1, (LENGTH(STR) DIV 3));
  Str3 := COPY(Str, (LENGTH(STR) DIV 3) * 2 + 1, LENGTH(STR));

  WRITELN(Str2 + Str3 + Str1);

END.

{         Вариант b         }
PROGRAM Solution(INPUT, OUTPUT);

VAR
  Str: STRING;
  Str1: STRING;
  Str2: STRING;
  Str3: STRING;
  TempStr: STRING;

BEGIN
  WRITE('Введите строку: ');
  READLN(Str);
  Str1 := COPY(Str, 1, LENGTH(STR) DIV 3);
  Str2 := COPY(Str, LENGTH(STR) DIV 3 + 1, (LENGTH(STR) DIV 3));
  Str3 := COPY(Str, (LENGTH(STR) DIV 3) * 2 + 1, LENGTH(STR));

  WRITELN(Str3 + Str1 + Str2);

END.
0,0(0 оценок)
Ответ:
millykot2003
16.10.2021 16:59
{ ответ дан на языке Pascal }
{         Вариант a         }
PROGRAM Solution(INPUT, OUTPUT);

VAR
  Str: STRING;
  Str1: STRING;
  Str2: STRING;
  Str3: STRING;
  TempStr: STRING;

BEGIN
  WRITE('Введите строку: ');
  READLN(Str);
  Str1 := COPY(Str, 1, LENGTH(STR) DIV 3);
  Str2 := COPY(Str, LENGTH(STR) DIV 3 + 1, (LENGTH(STR) DIV 3));
  Str3 := COPY(Str, (LENGTH(STR) DIV 3) * 2 + 1, LENGTH(STR));

  WRITELN(Str2 + Str3 + Str1);

END.

{         Вариант b         }
PROGRAM Solution(INPUT, OUTPUT);

VAR
  Str: STRING;
  Str1: STRING;
  Str2: STRING;
  Str3: STRING;
  TempStr: STRING;

BEGIN
  WRITE('Введите строку: ');
  READLN(Str);
  Str1 := COPY(Str, 1, LENGTH(STR) DIV 3);
  Str2 := COPY(Str, LENGTH(STR) DIV 3 + 1, (LENGTH(STR) DIV 3));
  Str3 := COPY(Str, (LENGTH(STR) DIV 3) * 2 + 1, LENGTH(STR));

  WRITELN(Str3 + Str1 + Str2);

END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота