nastya02012007
29.06.2020 22:12

Как я понял язык Паскаль)
Напишите программу для следующих задач
1) в последовательности целых чисел определить количество нечётных чисел, кратных 3. Количество введённых чисел неизвестно, но после ввода 0 ввод чисел заканчивается. Программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечётных чисел, кратных 3.
2) В последовательности целых чисел определить их количество и сумму чётных чисел. Количество введённых чисел неизвестно, но после ввода 0 ввод чисел заканчивается. Программа должна вывести два числа: длину последовательности и сумму чётных чисел.
3) В последовательности целых чисел определить их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256. Количество введённых чисел неизвестно, но после ввода 0 ввод чисел заканчивается. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256
4) В последовательности натуральных чисел определяет количество всех чётных чисел, кратных 5. Количество введённых чисел неизвестно, но после ввода 0 ввод чисел заканчивается. Программа должна вывести одно число: количество всех чётных чисел, кратных 5.
5) В последовательности натуральных чисел определяет количество всех чётных чисел, кратных 9. Количество введённых чисел неизвестно, но после ввода 0 ввод чисел заканчивается. Программа, должна вывести одно число: количество всех чётных чисел, кратных 9.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Viralave
28.02.2023 13:16

#include<iostream>

using namespace std;
int main(){
int N;
int *arr;
cout << "enter size of arr(enter N) : ";
cin >> N;
arr = new int [N];

for(int i = 1; i <= N;i++)
cin >> arr[i];
cout << "your arr : ";
for(int i = 1; i <= N;i++)
cout << arr[i] << " " ;

cout << "new arr : ";
for(int i = N; i > 0;i--)
cout << arr[i] << " " ;

cout << "new2 arr : ";
for(int i = 1; i <= N;i++)
{
if((i % 2) == 0)
cout << arr[i] << " " ;
}
}

0,0(0 оценок)
Ответ:
jhgdfkjg
04.06.2021 14:00

Если это Вам нужно для завтрашнего ГИА посторайтесь запомнить основные фигуры Черепашки. Если Вам предлагается команда [вперед n направо 72] то получится правильный пятиугольник; [вперед n направо 120] правильный треугольник; [вперед n направо 60] правильный шестиугольник; [вперед n направо 90] правильный четырех угольник, он же квадрат. Обращайте внимание на кол-во раз которое нужно повторить команду, если например вам будет дано повтори 4 [вперед n направо 60] то получится незамкнутая ломаная линия, о шестиугольнике и речи идти не может. расстояние которое черепашка должен пройти вперед не имеет никакого значения, главное чтоб оно было больше единицы, чтоб он не крутился на месте.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота