Войти
Регистрация
Спроси ai-bota
kudesnik72rusoz03b4
01.08.2022 00:25
Написать в C# и составить блок-схему:
Напишите программу, которая выводит на экран фразу «Всем привет» 80
раз – в таблице из 20 строк по 4 столбца. Для расстояния между колонками
использовать 5 пробелов
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
ятупик2
03.07.2022 21:22
Дед борис празднует каждый свой день рожд. в 2000 году он отпраздновал пятнадцатый раз день своего рождения. когда родился дед борис?...
Марося
24.02.2020 23:55
Вбазе данных хранятся записи, содержащие информацию о датах. каждая запись содержит три поля: год (число от 1 до 2100), номер месяца (число от 1 до 12) и номер дня в месяце (число...
неведимка17108
22.03.2020 11:51
Составить программу вычисления площади круга по заданному радиусу. печатать целую часть результата; дробную часть; остаток от деления на 3(не забудьте, что mod работает с целым...
Sofiamarfiya
23.03.2021 18:17
Запишите состоящий из четырех десятичных чисел из адреса 115.130.23.74 в 32 битном виде...
mashacherevchenko
15.05.2021 21:56
Известно количество жителей государства и площадь ее территории.определить плотность населения в этом государстве.написать решение в программе паскаль авс...
larisa115
18.07.2022 03:15
Введи в ячейку А1 значение 12,6, с автозаполнения протяни до ячейки А5. Выбери формат для каждой ячейки свой: процентный, числовой (кол-во знаков после запятой 5), дробный, текстовый,...
LilllOOo
22.05.2023 23:35
Перед открытием основногоОкна программы появляетсяОкно выбора одного изготовых *советов рисунков шаблонов...
svitlanaholenkp0an3s
07.03.2021 01:53
составить электронную таблицу прайс-листа магазина, указав столбцы и строки ячеек Таблица расчета товаров магазина. ...
lotostp
29.01.2020 12:18
Приведите по три примера на папка-файл каталог...
lilytrap
04.01.2023 15:59
Найдите абсциссы точек пересечения графиков функций у=3х-1 и у= -21/х+5....
Ответ:
sonyachu
25.05.2022 20:07
Результат работы и листинг программы в приложениях.
Написано в PascalABC.NET но должно работать во всех Паскалях.
----------------------------
PROGRAM A20;
CONST
max = 100;
TYPE
matrix = array[1..max,1..max]of shortint;
VAR
ar:matrix;
num:byte;
i,j:byte;
a,b,c:byte;
q:boolean;
BEGIN
repeat
// num := 5;
write('Введите размер матрицы n=');
readln(num);
for i:=1 to num do begin
for j:=1 to num do
read(ar[i,j]);
end;
i:=1;//диагональ
q:=true;
while q and (i<num) do begin
j:= i+1;//колонка и ряд
while q and (j<=num) do begin
a := ar[j,i];
b := ar[i, j];
if (ar[j,i] <> ar[i, j])
then q:=false;
j:=j+1;
end;
i:=i+1;
end;
if q then
writeln('YES')
else
writeln('NO');
write('Введите 1 чтобы продолжить. 0 чтобы завершить');
readln(i)
until(i=0);
END.
0,0
(0 оценок)
Ответ:
Versysbatl
07.10.2021 13:33
Ппц заданий сложный как у тарчка
1. Конвертировать число во float не постандарту IEEE-754
-53.45 (10) = -110101.01110011001 (2)
экспоненциальная запись = -1.1010101110011001 * 10^5
мантисса = -1.1010101110011001
порядок ^5 (10) = 101 (2)
дробная мантисса = 1010101110011001
дробный порядок = 101 + 1111 = 10100
знак минус = 1
ответ:
1 10100 10101011100110010000000000
2. Конвертировать из float не постандарту IEEE-754
исходное 0 100001 1010011010000000000000000
знак = 0
порядок = 100001 - 11111 = 10 = 2 (10)
мантисса = 1.101001101
110.1001101 (2) = 6.6015625 (10) корочи пребризительная 6.6
ответ 6.6015625
всё приблизительно за меня потомучта делал конвертер в местах перевод из 10 в двоичную и наборот а далши я сам поэтому пиши преблезительна
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота