ilnasgo54
03.02.2020 11:53

Определите в массиве A номер первого элемента, равного X.
Определите номер первого элемента, равного X, в первой половине массива A (массив имеет чётное число элементов).
Определите номер первого элемента, равного X, во второй половине массива A (массив имеет чётное число элементов).
Определите номер последнего элемента, равного X, во второй половине массива A (массив имеет чётное число элементов).
Определите, сколько есть элементов, равных X, в первой половине массива A (массив имеет чётное число элементов).
Определите, сколько в массиве A пар соседних элементов, значения которых одинаковы и равны заданному X.
Заполнить массив из 10 элементов случайными числами в интервале [-10..10] и отсортировать его по убыванию.
Пример:
Исходный массив:
4 5 -8 3 -7 -5 3 1 0 9
Результат:
9 5 4 3 3 1 0 -5 -7 -8
Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре.
Пример:
Исходный массив:
14 25 13 30 76 58 32 11 41 97
Результат:
30 11 41 32 13 14 25 76 97 58

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
натали574
22.06.2022 05:52
Дано:
Учеб - 200 стр
1 стр - 35 строк
1 строка - 50 символов
Решение:
1) 50*35=1750 (символов) - на одной странице
2) 1750*200=350000 (символов) - в учебнике
3) так как в задаче не указан метод кодировки, то будем использовать кодировку ASCII ( в ней 1 символ равен 1 байту, также есть кодировка UNICODE, в которой 1 символ равен 2 байтам).
Итак, 1 символ = 1 байту, тогда
350000*1=350000 (байт)
350000/1024 = 341,7 (Кб) - объём одного учебника.
4) переведём 2 Гб в Кб
2 Гб*1024 = 2048 (Мб)
2048*1024= 2 097 152 (Кб)
5) Разделим полученный объём на объём одного учебника:
2 097 152/341,7 = 6137 (учебников)
0,0(0 оценок)
Ответ:
Ghhgfgh
26.04.2021 01:14
// PascalABC.Net

function IsNice(n:longint):boolean;
// Отвечает на вопрос, является ли число красивым
var
  d,nd,sd:byte;
begin
  sd:=0; nd:=0;
  repeat
    d:=n mod 10;
    sd:=sd+d; Inc(nd);
    n:=n div 10
  until n=0;
  IsNice:=(sd mod nd = 0)
end;

var
  i,n,k:longint;
begin
  Write('Порядковый номер "красивого" числа: '); Read(n);
  i:=1; k:=0;
  repeat
    if IsNice(i) then Inc(k);
    if k<>n then Inc(i)
  until k=n;
  Writeln('Красивое число равно ',i)
end.

Тестовое решение:
Порядковый номер "красивого" числа: 15
Красивое число равно 20
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота