chapaev1981
13.03.2021 18:45

Напишите программу вычисления площадь треугольника S если известны основание a и высота h используя алгоритмический программирования​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
VIDAL17
04.01.2020 16:26
Ну и вопрос.. . это служебные клавиши которые выполняют специфические задачи в разных преложениях (программах) например 
Таблица горячих клавиш для MS Word: 
(эта таблица горячих клавиш Вам сделать работу с программой более эффективной, использование даже нескольких основных сочетаний горячих клавиш Word, при работе с программой заметно ускорить процесс создания и редактирования документов) . 

Горячие клавиши word: 
F1 - Вызов справки или
F2 - Перемещение текста или рисунков 
F3 - Вставка элемента автотекста 
F4 - Повторить последнее действие 
F5 - Перейти (меню «Правка» ) 
F6 - Переход к следующей области 
F7 - Правописание (меню «Сервис» ) 
F8 - Расширение выделения 
F9 - Обновление выделенных полей 
F10 - Перейти в строку меню 
F11 - переход к следующему полю 
F12 - Выполнить команду Сохранить как (меню «Файл» ) 

SHIFT+: 
F1 - Вызов контекстной справки 
F2 - Копирование текста 
F3 - Изменение регистра букв 
F4 - Найти или Перейти далее 
F5 - Переход к предыдущему исправлению 
F6 - Перейти в предыдущую область окна 
F7 - Тезаурус (меню «Сервис» ) 
F8 - Уменьшение выделения 
F9 - Отображение кодов или значений полей 
F10 - Вывести контекстное меню 
F11 - переход к предыдущему полю 
F12 - Выполнить команду Сохранить (меню «Файл» ) 

ALT+: 
F1 - Переход к следующему полю 
F3 - Создание элемента автотекста 
F4 - Выход из Word 
F5 - Прежние размеры окна программы 
F7 - Следующая ошибка 
F8 - Запуск макроса 
F9 - отображение кодов или значений всех полей 
F10 - развёртывание окна программы 
F11 - Отображение кода VISUAL BASIC 

CTRL+ ALT+: 
F1 - Сведения о системе 
F2 - Открыть (меню «Файл» ) 

CTRL+: 
F2 - предварительный просмотр 
F3 - Удаление выделенного фрагмента в копилку 
F4 - Закрытие окна 
F5 - Прежние размеры окна документа 
F6 - Переход к следующему окну 
F7 - Переместить (оконное меню) 
F8 - Размер (оконное меню) 
F9 - вставка пустого поля 
F10 - Развернуть или восстановить окно документа 
F11 - блокировка поля 
F12 - Выполнить команду Открыть (меню «Файл»)
0,0(0 оценок)
Ответ:
dashak20022
04.01.2020 16:26
Type
  tR = real;
  tF = file of tR;

procedure SwapFile(fn1, fn2: string);
var
  r: tR;
  fin, fout: tF;
begin
  Assign(fin, fn1); Reset(fin);
  Assign(fout, fn2); Rewrite(fout);
  while (not Eof(fin)) do begin Read(fin, r); Write(fout, r) end;
  Close(fin); Close(fout)
end;

var
  f1, f2, f3, f4, f5, fh: string;

begin
  f1 := 'f1.bin'; f2 := 'f2.bin'; f3 := 'f3.bin';
  f4 := 'f4.bin'; f5 := 'f5.bin'; fh := 'tmp.bin';
  { f2 <-> f4 }
  SwapFile(f2, fh); SwapFile(f4, f2); SwapFile(fh, f4);
  { f5->h, f3->f5, f1->f3, h->f1 }
  SwapFile(f5, fh); SwapFile(f3, f5); SwapFile(f1, f3); SwapFile(fh, f1)
end.

Для тестирования
Можно создать тестовые файлы с следующей программы:
type
  tR = real;
  tF = file of tR;

procedure WF(fn: string; m, n: integer);
var
  fout: tF;
  i: integer;
begin
  Assign(fout, fn); Rewrite(fout);
  for i := m to n do Write(fout, i / 2);
  Close(fout)
end;

var
  f1, f2, f3, f4, f5: string;

begin
  f1 := 'f1.bin'; f2 := 'f2.bin'; f3 := 'f3.bin';
  f4 := 'f4.bin'; f5 := 'f5.bin';
  WF(f1, 3, 7); WF(f2, 11, 19); WF(f3, -6, 9); WF(f4, 0, 11); WF(f5, 14, 22);   
end.

Далее можно просмотреть содержимое созданных файлов с следующей программы:
type
  tR = real;
  tF = file of tR;

procedure WF(fn: string);
var
  fin: tF;
  r: tR;
begin
  Writeln(fn);
  Assign(fin, fn); Reset(fin);
  while (not Eof(fin)) do
  begin Read(fin, r); Write(r:0:1, ' ') end;
  Writeln;
  Close(fin)
end;

var
  f1, f2, f3, f4, f5: string;

begin
  f1 := 'f1.bin'; f2 := 'f2.bin'; f3 := 'f3.bin';
  f4 := 'f4.bin'; f5 := 'f5.bin';
  WF(f1); WF(f2); WF(f3); WF(f4); WF(f5)
end.

Затем выполнить основную программу по перезаписи и снова запустить программу для просмотра обновленнных файлов.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота