123ЭщКеРе123
07.09.2021 16:37

Дан одномерный целочисленный массив A[15]. Элементы массива вводятся с
клавиатуры. Написать программу, которая будет находить сумму положительных
элементов массива, стоящих на нечетных местах.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ванесса07
30.07.2020 13:05

var A: array [1..15] of integer;

var i,s: integer;

begin

s:=0;

for i:=1 to 15 do

 begin  

 read(A[i]);

 if (A[i]>0) and (i mod 2 <>0) then s:=s+A[i];

 end;

writeln('Сумма положительных',

' элементов массива, стоящих на нечетных местах: ',s);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота