3333231231
14.12.2021 07:00

Написать программу Pascal
Написать программу, которая находит данные впрежения

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
54783
02.09.2021 11:03
2
а)
INPUT "Ширина первого прямоугольника";A1
INPUT "Длина первого прямоугольника";B1
INPUT "Ширина второго прямоугольника";A2
INPUT "Длина второго прямоугольника";B2
IF A1/A2=B1/B2 THEN PRINT "Фигуры подобны" ELSE PRINT "Нет подобия"

б)
PRINT '"Первый треугольник:"
INPUT "Первая сторона";A1
INPUT "Вторая сторона";B1
INPUT "Третья сторона";C1
PRINT '"Второй треугольник:"
INPUT "Первая сторона";A2
INPUT "Вторая сторона";B2
INPUT "Третья сторона";C2
IF (A1/A2=B1/B2) AND (B1/B2=C1/C2) THEN PRINT "Фигуры подобны" ELSE PRINT "Нет подобия"
0,0(0 оценок)
Ответ:
MashaE631
16.05.2023 16:03
Uses  crt;const  nmax=100;var  a1,a2: array[1..nmax] of integer;  n,i,b,k,s: integer;begin  randomize;  clrscr;  repeat    write('Введите размер массива n (n in [1..',nmax,']): ');    readln(n);    write('Введите число B (0<B<100): ');    readln(b);  until (n in [1..nmax]) and (b in [1..99]);  writeln('Массив A1');  for i:=1 to n do  begin    a1[i]:=random(99);    write(a1[i]:4);    if a1[i]>b then    begin      inc(k);      a2[k]:=i;      s:=s+a1[i];    end;  end;  writeln;  writeln('Среднее элеметов, больших B = ',s/k:0:2);  writeln('Массив A2:');  for i:=1 to k do write(a2[i]:4);  readln;end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота