YMNIKVKOWICKAH
07.03.2021 12:41

Написать программу, которая вводит двумерный массив 3х3, выводит его на экран в виде матрицы, а затем выводит количество отрицательных элементов. Я программу написала, но не понимаю, где ошибка
program mas2;
const
m=3;
n=3;
var
i, j, c: Integer;
a: array [1..m, 1..n] of Integer;
begin
for i := 1 to m do
for j := 1 to n do
read (a[i,j]);
for i := 1 to m do
begin
for j := 1 to n do
write (a[i,j]:6);
writeln;
c := 0;
if a[i, j] < 0 then
c:=c+1;
end;
WriteLn('Количество отрицательных элементов равно ', c);
end.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Анасія
23.08.2020 19:51

Вы забыли поместить команды цикла в блок "begin-end", а также зачем-то внутри цикла каждый раз обнуляли переменную c. Взгляните на исправленный вариант:

program mas2;

const

m=3;

n=3;

var

i, j, c: Integer;

a: array [1..m, 1..n] of Integer;

begin

for i := 1 to m do

for j := 1 to n do

read (a[i,j]);

c := 0;

for i := 1 to m do

begin

for j := 1 to n do

begin  

write (a[i,j]:6);

if a[i, j] < 0 then

c:=c+1;

end;

writeln;

end;

WriteLn('Количество отрицательных элементов равно ', c);

end.


Написать программу, которая вводит двумерный массив 3х3, выводит его на экран в виде матрицы, а зате
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота