asemgul101205
10.06.2021 10:05

Написать программу сравнения двух чисел a и b, в результате программа должна наименьшее из этих чисел увеличить в два раза.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nikasuper09
06.11.2022 05:12
Const
    handsfree = true;

var
    a: array[1..100] of real;
    i, n: integer;
    min, max: real;
    k: integer;

begin
    {ввод массива}
    if handsfree then
        n := random(20) + 5
    else begin
        write('n = ');
        readln(n);
    end;
    
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(100);
            write(a[i], ' ');
        end
        else readln(a[i]);
    end;
    writeln();
    
    {подсчет элементов}
    k := 0;
    for i := 1 to n do
        if a[i] > 5 then k := k + 1;
    writeln(k);
end.
0,0(0 оценок)
Ответ:
olyazhili
23.07.2022 20:25
Не знаю на каком языке нужно написать, поэтому напишу словами. Берешь крч длину массива. Создаешь цикл for от 1-го элемента до длины массива (<=) . Потом ( пусть индекс элемаета массива это i ) ставишь два условия: 1) Если i-й элемент массива четный ( на c# это как-то так записывается - if arr[i] %2 = 0)
То этот элемент массива увеличиваешь на 7 (arr[i] = arr[i] + 7)
. 2) Условие 2 : Если число нечетное ( if arr[i] %2 != 0) , то arr[i] = arr[i] / 4.
И потом выводишь на экран если надо.
PS соррян за грамматику:)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота